Code PO 496 (Evap system) - Pontiac G8 Forum: G8 Forums - G8Board.com
Reply
 
LinkBack Thread Tools
post #1 of 46 (permalink) Old 11-17-2012, 03:00 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 40
Code PO 496 (Evap system)

Been getting this code a few times lately. Evap flow during a non purge condition. Any help would be appreciated.
Bennie77 is offline  
Sponsored Links
Advertisement
 
post #2 of 46 (permalink) Old 11-17-2012, 03:16 PM
Senior Member
 
Agose25's Avatar
 
Join Date: Oct 2009
Location: Frisco TX
Posts: 4,210
Check your gas cap. Untighten it and then tighten it back hearing the clicks several times. With the weather changing from warm to cold this is usually when gas caps get loose.

If your code doesnt go away check back in here...




Agose25 is offline  
post #3 of 46 (permalink) Old 11-17-2012, 03:52 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 40
Will do. Thanks.
Bennie77 is offline  
post #4 of 46 (permalink) Old 11-17-2012, 08:14 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 40
Well, I removed the neg battery cable to clear the code, tightened gas cap but the check engine light came on again.
Bennie77 is offline  
post #5 of 46 (permalink) Old 11-17-2012, 09:32 PM
Car RamRod
 
todds87ss's Avatar
 
Join Date: Aug 2008
Posts: 1,795
purge valve stuck open?
Disconnect it and blow through it. you should not be able to.
You can also connect a 12vdc source to it and verify it opens.

You can choose to be anything you want on the internet...why choose to be so stupid!
todds87ss is offline  
post #6 of 46 (permalink) Old 11-17-2012, 09:32 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 3,131
My read is saying, that the EVAP system is seeing a higher vacuum in the system, than it should. If the purge solenoid valve does not shutoff correctly, the intake manifold will keep adding vacuum to the fuel tank to the point that it exceeds the desired level, an will trip that fault code.
That purge solenoid valve sounds like its starting to fail. Its located just forward of the oil fill spout. If everything looks good from the outside (electrical connection and plumbing etc), maybe you could rap on it a little, to see if might temporarily correct itself. If so, you would then know what to buy, unless this is still covered by GM.
GOPHERIT is offline  
post #7 of 46 (permalink) Old 11-19-2012, 05:14 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 40
Quote:
Originally Posted by GOPHERIT View Post
My read is saying, that the EVAP system is seeing a higher vacuum in the system, than it should. If the purge solenoid valve does not shutoff correctly, the intake manifold will keep adding vacuum to the fuel tank to the point that it exceeds the desired level, an will trip that fault code.
That purge solenoid valve sounds like its starting to fail. Its located just forward of the oil fill spout. If everything looks good from the outside (electrical connection and plumbing etc), maybe you could rap on it a little, to see if might temporarily correct itself. If so, you would then know what to buy, unless this is still covered by GM.
I am not sure what I am looking for. Does someone have a diagram showing the part?

Thanks
Bennie77 is offline  
post #8 of 46 (permalink) Old 11-19-2012, 05:34 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 3,131
^^^^ I don't, but you couldn't ask for an easier part to get to and see. Remove your engine cover (if its still on), lift up the 2 heater hoses just a touch, where they pass by the front of the passenger side valve cover. There you will see a black plastic module about 2x2 in size. A vac line in and out, plus an elect connector attached to it. That *is* the purge valve.
GOPHERIT is offline  
post #9 of 46 (permalink) Old 11-19-2012, 07:10 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 40
I appreciate all the help, but at the risk of sounding stupid, I am confused. One says in front of oil fill on drivers side, the other in front of valve cover on Passenger side. I am stumped.
Bennie77 is offline  
post #10 of 46 (permalink) Old 11-19-2012, 07:49 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 3,131
^^^ Well I checked my post #6, to see if I goofed, but it only says *oil spout*. I don't know where the *drivers side info is coming from.


Added info---- I'm talking about this under the assumption that your car is indeed a V8. The fault, and cause is the same for a V6, but the valve is in a different location.

Last edited by GOPHERIT; 11-19-2012 at 08:32 PM. Reason: added info
GOPHERIT is offline  
post #11 of 46 (permalink) Old 11-19-2012, 09:58 PM
Car RamRod
 
todds87ss's Avatar
 
Join Date: Aug 2008
Posts: 1,795
Bennie, do a google image search for purge solenoid or purge valve on the G8. you will see what it should look like. It is an easy check.

You can choose to be anything you want on the internet...why choose to be so stupid!
todds87ss is offline  
post #12 of 46 (permalink) Old 11-20-2012, 12:18 AM
Senior Member
 
JESUSFREAK702's Avatar
 
Join Date: Jun 2011
Location: Las Vegas, NV
Posts: 214
Make sure there are no cracks in the gas cap. The evap code is almost always the cap. Its an emission code so the battery disconnect doesn't always work.

Mods
Tuned by Frank @ Revolution Raceworks
Rotofab CAI
Pacesetter LTH 1 3/4
cat delete
Pypes Violators w/magnaflow x pipe

Staggered 20" STR101
245/35R20 and 275/30R20 Delinte D7
D2 Coilovers
5% tint



JESUSFREAK702 is offline  
post #13 of 46 (permalink) Old 11-20-2012, 01:54 AM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 40
Quote:
Originally Posted by GOPHERIT View Post
^^^ Well I checked my post #6, to see if I goofed, but it only says *oil spout*. I don't know where the *drivers side info is coming from.


Added info---- I'm talking about this under the assumption that your car is indeed a V8. The fault, and cause is the same for a V6, but the valve is in a different location.
No. I have a V6! Oil spout is on drivers side. I am in V6 tech forum, correct?
Bennie77 is offline  
post #14 of 46 (permalink) Old 11-20-2012, 10:13 AM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 3,131
Bennie77, you are in the correct posting location. I have a habit of reading the thread, without verifying what section it is located in (my bad). If I read the diagrams correctly, the purge valve is located just above a couple of the spark plug coils, on the passenger side. It looks to be a cylindrical shape with a vac line at each end of it.
GOPHERIT is offline  
post #15 of 46 (permalink) Old 11-21-2012, 12:48 AM
Car RamRod
 
todds87ss's Avatar
 
Join Date: Aug 2008
Posts: 1,795
Quote:
Originally Posted by JESUSFREAK702 View Post
Make sure there are no cracks in the gas cap. The evap code is almost always the cap. Its an emission code so the battery disconnect doesn't always work.
p0455 is the cap code.

You can choose to be anything you want on the internet...why choose to be so stupid!
todds87ss is offline  
post #16 of 46 (permalink) Old 11-21-2012, 02:42 AM
Senior Member
 
JESUSFREAK702's Avatar
 
Join Date: Jun 2011
Location: Las Vegas, NV
Posts: 214
Quote:
Originally Posted by todds87ss View Post
p0455 is the cap code.
I humbly stand corrected.

http://www.obd-codes.com/p0496

Mods
Tuned by Frank @ Revolution Raceworks
Rotofab CAI
Pacesetter LTH 1 3/4
cat delete
Pypes Violators w/magnaflow x pipe

Staggered 20" STR101
245/35R20 and 275/30R20 Delinte D7
D2 Coilovers
5% tint



JESUSFREAK702 is offline  
post #17 of 46 (permalink) Old 11-21-2012, 06:54 AM
Senior Member
 
HotRodG8's Avatar
 
Join Date: Apr 2011
Location: Farmington Hills,MI
Posts: 173
Replace the EVAP purge solenoid. P0496 is EVAP purge during non-flow operation, which means the system is seeing vaccum while the system is being commanded sealed. this is caused by a purge solenoid being stuck open. part is $50 and is located on the pass side close to the intake manifold near the cowl... p0455 is EVAP large leak usually a cap left completely off or a EVAP vent valve stuck open.. P0442 is a EVAP small leak, usually a gas cap.... hope this helps

Owner @ MJD Performance "If you can dream it, we can build it"
2009 PBM G8 GT
Premium, Sport, Sunroof
LS3 Swapped
Lingenfelter Ported Heads
MJD Performance Custom Cam
RotoFab CAI
American Racing headers w/ GXP mufflers
PATC Custom 3400 Stall
Built 6L80e with 6L90e internals
FE3 Suspension
CTSV Coupe Wheels with Michelin PS2 rubber
473hp/459tq NA
--All New Setup in the work's for 2015 !!--
HotRodG8 is offline  
post #18 of 46 (permalink) Old 11-21-2012, 07:15 AM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 40
Well, I did check the gas cap previously. It looked fine. Anyway, got gas last night, and after filling up, the cel is no longer coming on. Coincidence? Maybe. I will keep an eye on it, and if the code returns, will look into the evap purge valve. Thank you all for your help!
Bennie77 is offline  
post #19 of 46 (permalink) Old 12-06-2012, 08:19 AM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 40
Well, the cel has come on intermittantly so I got a new purge valve. Now, any tips on getting the connectors off? Don't want to break anything. I was able to disconnect the electrical connector, but not sure how the others come off.
Thanks
Bennie77 is offline  
post #20 of 46 (permalink) Old 12-06-2012, 11:53 AM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 3,131
Wouldn't you know, they can't make it easy. They show you need a removal tool (the tool in the GM service manual is P/N EN-46843) It looks like a device that would slip around the pipe coming out of the valve an under the hose locking collar attached to it. It probably probably forces a locking ring outboard, so you could then pull the hose away from the valve over the raised retaining lip on the pipe. There might be an after market vendor that sells a tool, that will do what is needed here, say from an auto parts store. Might be a tough find. If a lot of GM cars use this same type of disconnect technique, maybe finding a tool won't be that hard.
GOPHERIT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome