Alternator, power steering, overheat at same time?? - Pontiac G8 Forum: G8 Forums - G8Board.com
 
Go Back   Pontiac G8 Forum: G8 Forums - G8Board.com > G8 Tech > V8 Engine Tech (L76/LS3)

» Auto Insurance
» Vendors
Reply
 
Thread Tools
Old 12-10-2012, 10:46 AM   #1
g8ace
Aceves Const 310-350-8040
 
g8ace's Avatar
 
Join Date: Apr 2008
Location: lynwood, next to compton CA.
Posts: 388
Default Alternator, power steering, overheat at same time??

Driving home on Saturday morning at 1:30 am and the car yells at me saying the alternator is no good, then over heating, and the car requires 24" pythons to turn the steering wheel. What gives, has this happened to anyone out there. Need to know if this is typical for a bad alternator.
FYI.... I took my car in for service about a month ago due to the crank pulley sheering right off of the crank. Maybe this two things are related??? need help guys.
__________________
RotoFab CAI, Full Solo exhaust, full tint at 5%, Breyton GTS rims, Debadged, 55 watt HID's 6000K and LED fog lights, and one bad ass driver!!!!
g8ace is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-10-2012, 11:02 AM   #2
whatnext
Senior Member
 
Join Date: Aug 2011
Location: Latham, NY
Posts: 645
Default

Maybe you lost the belt. Just guessing as it seems you lost the alternator and power steering at the same time.
whatnext is offline   Reply With Quote
Old 12-10-2012, 11:28 AM   #3
GT Drew
Senior Member
 
Join Date: Nov 2009
Location: Toronto, Canada
Posts: 2,261
Default

Open the hood before coming online. Was there any noise before the failure? Tensioner or idler pulleys are common failures that can cause the belt to just fall off the pulleys. So no waterpump, alternator or power steering.
__________________
'09 SRM GT. VCM Intake, Cortex, Solo H/F Cats, Solo Mach Balanced system. Whiteline Rear Subframe Bushing,Stop Tech street Pads, H9 Low Beams.
GT Drew is offline   Reply With Quote
Old 12-10-2012, 01:02 PM   #4
Joe'sFastG8
Senior Member
 
Joe'sFastG8's Avatar
 
Join Date: Jul 2012
Location: Appleton, WI
Posts: 457
Default

Agreed it sounds like you lost the belt. It might be an issue with the harmonic balancer since that was just worked on. Who performed the repairs and what all was repaired/replaced?
Joe'sFastG8 is offline   Reply With Quote
Old 12-10-2012, 01:19 PM   #5
GMCustomerService
Senior Member
 
GMCustomerService's Avatar
 
Join Date: Oct 2010
Location: Michigan
Posts: 1,550
Default

@g8ace, how are things going with the G8 this afternoon? Did you check your belt?

Michelle, GM Customer Service
GMCustomerService is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:07 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2007-2008, G8Board.com

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.