Antifreeze / coolant leak - water pump going after only 15k? - Pontiac G8 Forum: G8 Forums - G8Board.com
 
Go Back   Pontiac G8 Forum: G8 Forums - G8Board.com > G8 Tech > V8 Engine Tech (L76/LS3)

» Auto Insurance
» Vendors
Reply
 
Thread Tools
Old 02-04-2010, 09:32 AM   #1
l.i. bruce fan
GP GT -> G35x -> G8 GT
 
l.i. bruce fan's Avatar
 
Join Date: May 2008
Location: Long Island, New York
Posts: 82
Default Antifreeze / coolant leak - water pump going after only 15k?

The title says it all. Found a small puddle in the garage under my GT (18 months in service, 15,100 miles) took it in and dealer (Chevy dealer BTW) says water pump is leaking.

I think I have changed maybe one water pump in all the cars I have owned in 26 years and I am somewhat surprised that this happened, especially so soon.

Anyone else with similar experience? (I searched the forum and only found two guys with radiator leaks).

Also, any thoughts on going with Chevy dealer for service?

My reasons were lack of acceptable Pontiac dealers locally and thought that Chevy dealers would have experience with L76 given that it is used in some of their SUVs and trucks.
__________________
L.I. Bruce Fan
2008.5 G8 GT
Liquid Red with Onyx/Red
Premium Package
Sunroof
l.i. bruce fan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-04-2010, 10:50 AM   #2
DRCUSTOMPARTS
Banned
 
Join Date: Dec 2008
Location: Chicagoland
Posts: 7,067
Default

Parts aren't 100% fail proof in manufacturing, it's know as a defective part. There's nothing wrong with having a Chevy dealer fix your car, they are trained by GM just like the guys at the Pontiac dealers.
DRCUSTOMPARTS is offline   Reply With Quote
Old 02-04-2010, 11:06 AM   #3
BigV8
Senior Member
 
BigV8's Avatar
 
Join Date: Jan 2009
Location: SC USA
Posts: 1,313
Default

I know that the 5.3 in my 99 truck is close family to the 6.0 as far as the water pump design. So what i had on my truck was a leak but only when it was cooled down. It was not out of the weep hole but after removing the pump found out it came from one the metal gaskets with the built in rubber seal. That was a first for me. I guess they probably did give you the details? Just sharing my experience.
__________________
09 GXP SRM A6 w/sunroof. Mods:Livernois Maggie 2.3, 3.0" pulley, 160 stat, KB Bap. Rotofab,Corsa, Kooks 1 7/8 mids, BMR,Pedders supercar coilovers, all Brembos, CTS-V rims, Hids, halos, leather console lid. HSV gauges. 502rwhp,479tq#873 of 1829 and 1 of 169 in SRM.
BigV8 is offline   Reply With Quote
Old 02-04-2010, 12:00 PM   #4
l.i. bruce fan
GP GT -> G35x -> G8 GT
 
l.i. bruce fan's Avatar
 
Join Date: May 2008
Location: Long Island, New York
Posts: 82
Default

Quote:
Originally Posted by BigV8 View Post
I know that the 5.3 in my 99 truck is close family to the 6.0 as far as the water pump design. So what i had on my truck was a leak but only when it was cooled down. It was not out of the weep hole but after removing the pump found out it came from one the metal gaskets with the built in rubber seal. That was a first for me. I guess they probably did give you the details? Just sharing my experience.
No details yet, will share once I have them.

And Dr. Custom - I'm familiar with the concept of a defective part, I was just surprised with the defect considering the limited amount of use/time and my past experiences, and was wondering if others had similar experiences.
__________________
L.I. Bruce Fan
2008.5 G8 GT
Liquid Red with Onyx/Red
Premium Package
Sunroof
l.i. bruce fan is offline   Reply With Quote
Old 02-04-2010, 12:08 PM   #5
DRCUSTOMPARTS
Banned
 
Join Date: Dec 2008
Location: Chicagoland
Posts: 7,067
Default

I've been around long enough to realize that defects aren't surprising, and this is no exception.
DRCUSTOMPARTS is offline   Reply With Quote
Old 02-04-2010, 01:20 PM   #6
MRM
Senior Member
 
MRM's Avatar
 
Join Date: Jan 2008
Location: Powell, TN
Posts: 555
Default

On my '97 GP, I replaced the water pump twice on it. Once was right after I bought it with roughly 48k miles on it and the other was over 160k miles.
MRM is offline   Reply With Quote
Old 02-05-2010, 02:59 PM   #7
91Firehawk
GXPanther
 
91Firehawk's Avatar
 
Join Date: Dec 2008
Location: Austin, Tx
Posts: 804
Default

Quote:
Originally Posted by l.i. bruce fan View Post
The title says it all. Found a small puddle in the garage under my GT (18 months in service, 15,100 miles) took it in and dealer (Chevy dealer BTW) says water pump is leaking.

I think I have changed maybe one water pump in all the cars I have owned in 26 years and I am somewhat surprised that this happened, especially so soon.

Anyone else with similar experience? (I searched the forum and only found two guys with radiator leaks).

Also, any thoughts on going with Chevy dealer for service?

My reasons were lack of acceptable Pontiac dealers locally and thought that Chevy dealers would have experience with L76 given that it is used in some of their SUVs and trucks.
i had the same thing on my G8. took it in they did a pressure check to find the leak and they said it was the water pump. it took them a week to get one before they could do the install
__________________
'09 G8 GXP M6
TVS1900 - LS9 injectors - 1 7/8 LTs - Kooks Xpipe - SLP PowerFlows w/SOLO J-Pipes - CAI - MGW Shifter - McLeod TwinDisc - Squash Performance Fuel
BMR Sways / trailing arms - Eibach Pro-Kit - GForce Half-shafts - '09 CTS-V wheels 19x9/9.5 w/255-285
_____________________________________________________
'91 Fir
ebird - Fastburn crate motor, T56 6speed - gone but not forgotten
91Firehawk is offline   Reply With Quote
Old 02-13-2010, 06:12 PM   #8
BrandonG8Man
Junior Member
 
BrandonG8Man's Avatar
 
Join Date: Feb 2008
Location: Tampa, FL
Posts: 8
Default 24k and just had same issue.

Had a small pink puddle in the garage under the engine. Took it in and they diagnosed the water pump after a pressure test. In my case they had the pump in stock so had it fixed the same day. A bit unusual but definitely still love my 08 GT!
BrandonG8Man is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:50 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2007-2008, G8Board.com

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.