Cel - p0030 - Pontiac G8 Forum: G8 Forums - G8Board.com
 
Go Back   Pontiac G8 Forum: G8 Forums - G8Board.com > G8 Tech > V8 Engine Tech (L76/LS3)

» Auto Insurance
» Vendors
Reply
 
Thread Tools
Old 11-13-2012, 04:51 PM   #1
Ewing
Senior Member
 
Ewing's Avatar
 
Join Date: Aug 2008
Location: Dania Beach, FL
Posts: 994
Question Cel - p0030

I have P0030 code coming up which is:

HO2S HEATER CONTROL CIRCUIT/BANK 1 SENSOR 1

This is supposed to be the driver's side 02 sensor's heating element going bad. I've read around that before just replacing the sensor, it would be good to check some fuse because that might be it and not the sensor itself. Does anyone know where this fuse is? I checked the fuse box under the hood and I see one fuse that says Emissions 1 and another Emissions 2. Are those the fuses?
__________________

404ci Forged & Stroked|Livernois Stage 1 Cam|Roto-Fab|Kooks LT's & X-Pipe|Ported TB & Intake|Pedderized with BMR sprinkles|JHP Nav Kit|Much ICE|Ceramic Tints|3rd Shift & Holden Emblems|Gloss Black Camaro Brembos|Bluetooth and XM retrofit|5000K HID's|Roof Spoiler|TCS 3200RPM Stall|Earl's tranny,oil & ps coolers|12.3@109MPH|440HP|410TQ|
Ewing is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-13-2012, 07:21 PM   #2
GOPHERIT
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 2,326
Default

You got the position correct. There are *2* fuses that supply the heater power to the *4* sensors. They are F33--15A *Emission 1*, controlling banks 1 an 2 #1 sensors. An F32---15A *Emission 2*, controlling banks 1 an 2 #2 sensors. Both fuses are located in the underhood fuse box. Heaters due go bad, but the sensor most likely can still send back the proper signals. It would just make that sensor take a much longer time getting up to the proper operating temp. Which it needs to do as fast as possible for proper (best) control of the fuel/air mixture.
It sounds like the other bank ops normal. So I doubt there is any fuse problem here.
GOPHERIT is offline   Reply With Quote
Old 11-13-2012, 07:49 PM   #3
Ewing
Senior Member
 
Ewing's Avatar
 
Join Date: Aug 2008
Location: Dania Beach, FL
Posts: 994
Default

Thanks. I think you're right because it takes some time after I clear the code for the CEL to come back. If the fuse was bad the CEL would just come back right away after being cleared right?


Sent from my iPhone using Autoguide.com App
__________________

404ci Forged & Stroked|Livernois Stage 1 Cam|Roto-Fab|Kooks LT's & X-Pipe|Ported TB & Intake|Pedderized with BMR sprinkles|JHP Nav Kit|Much ICE|Ceramic Tints|3rd Shift & Holden Emblems|Gloss Black Camaro Brembos|Bluetooth and XM retrofit|5000K HID's|Roof Spoiler|TCS 3200RPM Stall|Earl's tranny,oil & ps coolers|12.3@109MPH|440HP|410TQ|
Ewing is offline   Reply With Quote
Old 11-13-2012, 09:19 PM   #4
GOPHERIT
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 2,326
Default

That fault code, as well as others that monitor the operation of the heater portion of the H02S, are listed as *B* rated type faults (as in you have a problem here, but will give it another try). It says that after a reset, it will not illuminate the MIL until the 2nd engine start/run event is under way. So the sensor could pass on the second attempt, an you wouldn't even know it flunked on the 1st start/run cycle.
So even if it pops up on the 2nd cycle, all subsequent start cycles will display the Mil light, until a fix is performed. You best buy a new sensor, and possibly even a matching pair, if you've got the bucks. The opposite side may have a short life left in it.
GOPHERIT is offline   Reply With Quote
Old 11-14-2012, 10:36 AM   #5
Ewing
Senior Member
 
Ewing's Avatar
 
Join Date: Aug 2008
Location: Dania Beach, FL
Posts: 994
Default

I went ahead and ordered the driver's side sensor. Hope that takes care of it. Will have to wait until next week when it gets here.




Sent from my iPhone using Autoguide.com App
__________________

404ci Forged & Stroked|Livernois Stage 1 Cam|Roto-Fab|Kooks LT's & X-Pipe|Ported TB & Intake|Pedderized with BMR sprinkles|JHP Nav Kit|Much ICE|Ceramic Tints|3rd Shift & Holden Emblems|Gloss Black Camaro Brembos|Bluetooth and XM retrofit|5000K HID's|Roof Spoiler|TCS 3200RPM Stall|Earl's tranny,oil & ps coolers|12.3@109MPH|440HP|410TQ|
Ewing is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:36 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2007-2008, G8Board.com

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.