Help with bad rattling noise on start up - Pontiac G8 Forum: G8 Forums - G8Board.com
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 03-12-2015, 12:04 PM Thread Starter
Junior Member
 
Join Date: May 2010
Posts: 9
Help with bad rattling noise on start up

Hi everyone,

I own a 2008 Pontiac G8 V6 with 104k miles and lately on cold mornings whenever I start the car it makes this awful rattling sound then stops and everything seems fine, What I have noticed:

It only happens on cold mornings
Car runs fine after the rattling
If it's a hot out it doesn't do it
No check engine light
Rest of the day seems fine
I don't use the car daily

Here's the video
https://www.youtube.com/watch?v=1nsmncAMRJQ

I know I should take it to the shop but lately the weather has been horrible here in Texas and I been working a lot and not enough time to take it to the shop, plus is over the 100k warranty.

Any help is appreciated, thanks!
Zepia is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-12-2015, 03:23 PM
Member
 
Djmac's Avatar
 
Join Date: Feb 2009
Location: Niagara, Ontario
Posts: 62
Check for loosened transmission heat shield for starters. Rivets let go.
Djmac is offline  
post #3 of 8 (permalink) Old 03-12-2015, 07:45 PM Thread Starter
Junior Member
 
Join Date: May 2010
Posts: 9
Quote:
Originally Posted by Djmac View Post
Check for loosened transmission heat shield for starters. Rivets let go.
I think the noise it's coming more from the engine side of things, I watched a few videos of loose transmission heat shields and it's not a constant noise, it only happens after the car has been cold for 8+ hours.

It almost sounds like the engine wants to lock itself.
Zepia is offline  
 
post #4 of 8 (permalink) Old 03-15-2015, 06:12 AM
Senior Member
 
Join Date: Sep 2010
Location: Cumberland, RI
Posts: 316
May be a waste of time but try doing it with the Serpentine belt. Make sure the engine oil is full. It kind of points to a pretty serious case of timing chain noise to me.


Sent from AutoGuide.com Free App


2008 Pontiac G8 | LY7 V6 | 6L50 AT Conversion | 3.45 LSD Rear Differential | Panther Black Metallic | GT Tail Lamps | Red Leather Seats | GXP Rear Diffuser

1957 Oldsmobile 98 | 371 Rocket V8 | J2 3x2 Tri Power| Jetaway Dual Coupling Hydra-Matic | Sierra Gold | Magnaflow Dual Exhaust | Autronic Eye
kgenesse is offline  
post #5 of 8 (permalink) Old 04-04-2016, 01:05 PM
Junior Member
 
Join Date: Apr 2016
Posts: 2
Hey there mine is doing the same thing have you had any updates?
RichensG8 is offline  
post #6 of 8 (permalink) Old 04-05-2016, 12:58 AM
Les
OGOC Member
 
Les's Avatar
 
Join Date: Jul 2012
Location: Oshawa,Ont. Canada
Posts: 2,601
Garage
Could probably be the idler pulls.

OGOC Member
2009.1 G8 SV6 Tuned.
Overkill Tune 3rd Gen.
GT Intake system
76mm Throttle body.
X-Pipe,Custom Axlebacks.
3/4" Intake Spacers.
GXP Front Clip,GXP Diffuser.
K&N CAI
Custom Rad Cover.
10" Pioneer Sub and Box.
And More....

[SIGPIC][/SIGPIC]
Les is offline  
post #7 of 8 (permalink) Old 04-05-2016, 12:24 PM
Junior Member
 
Join Date: Apr 2016
Posts: 2
Hey guys so I used MOA by BG over the winter months and it stopped the noise from happening. Same issue of sitting overnight and next morning upon start up sure enough it would make the horrible sound. After using the MOA it helped a lot. I recently had the oil changed and the noise came back for obvious reasons. I reordered the MOA and will update again when it is here. Should be this week or the start of next. If I recall it started working immediately. I do not believe in can cures but this one certainly did help.
RichensG8 is offline  
post #8 of 8 (permalink) Old 06-07-2016, 08:52 AM
Junior Member
 
Join Date: Jun 2014
Location: San Antonio, TX
Posts: 13
I have had the same problem. On some cold days it is bad enough to kill the engine. It is not a case of bad timing chains as mine are brand new and this happened before and after the change out. I wonder if it is an issue with the oil pump needing to build up pressure in the engine. That's the only thing I can think of. Let me know if any of you find out anything on this.
TJ07 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome