Finally got the dreaded cel after my 3rd mod. - Pontiac G8 Forum: G8 Forums - G8Board.com
 
LinkBack Thread Tools
post #1 of 19 (permalink) Old 04-21-2019, 11:34 AM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Finally got the dreaded cel after my 3rd mod.

I bought my 2009 base G8 back in November so about 6 months ago. Really clean one owner car with 86k on it. I wanted to do a few bolt on mods so first I put a K&N cold air intake on. No issues and I really like it. Next, two weeks ago I put a Magnaflow True X pipe/muffler in place of the mid muffler and a nice Magnaflow axle back exhaust with dual tips. Again, very happy with the results and no issues.

Well a few days ago I installed a really nice catch can from Mace and on my way home from work, my cel came on. I scanned it and it came up with a lean code(actually a few codes but all related). I cleared the codes and it was fine until I was almost home from work. Work is approximately 20 miles away.

I'm assuming there is a vacuum leak somewhere in the catch can system. Possibly the drain plug may not be tight. I've read that is a common misoverlooked mistake.

My question is... will it be ok to drive it around until I can get it back to the shop? Thanks in advance.
rockinlespaul is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 04-22-2019, 12:12 PM
Senior Member
 
PONY MAN's Avatar
 
Join Date: Mar 2010
Location: EARTH :-/
Posts: 4,358
There are a variety of reasons why the car is running lean and unfortunately the check engine codes were erased and could have helped to pinpoint the culprit. The vehicle should be safe to drive for a short while until the problem is found and fixed. However, if the car is running noticeably poorer then disregard the previous statement. Good luck.

#NEVER GIVE UP
#AUDACITY OF HOPE

"Rather not run the risk of offending anyone, so let me just go ahead and offend someone". -PONY MAN

"When you write the story of your life, don't let anyone else hold the pen". -UNKNOWN














PONY MAN is offline  
post #3 of 19 (permalink) Old 04-23-2019, 07:23 AM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Thanks Pony Man. I'm going to take it up to my shop today and see if I can't find the issue. The cel came back on. The codes were a P2187 and P2189. I'm sure it's either a vacuum leak in the catch can routing or a leak in the exhaust.
rockinlespaul is offline  
 
post #4 of 19 (permalink) Old 04-23-2019, 07:24 AM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
No power loss whatsoever by the way.
rockinlespaul is offline  
post #5 of 19 (permalink) Old 04-23-2019, 07:37 AM
Senior Member
 
ebg8gt's Avatar
 
Join Date: Jan 2017
Location: Mount Airy, MD
Posts: 569
I've had exhausts leaks cause lean CEL. It takes a number of start cycles to throw the CEL though. It will store a pending fault until then.

Try scanning for codes even with the CEL off, you might get a pending fault.

2009 PBM GT
Under the Knife Again
Wiseco Pistons, K1 Rods, Johnson Lifters, BLP Keep Hatin' PDS Cam, Roto-Fab, BLP Ported Intake and Throttle Body, Kooks 1-7/8 long tubes, XForce Varex Catback, ZL1 Converter, Camaro Trans Pan/Filter, GXP Brembos
Breyton GTS-AV Wheels, 6k HIDs, Holden Steering Wheel and Paddle Shifters, Eibach Springs, 35% Tint
Tuned by Day Tuning
ebg8gt is offline  
post #6 of 19 (permalink) Old 04-23-2019, 07:42 AM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Thanks, I will do that! Appreciate the input!
rockinlespaul is offline  
post #7 of 19 (permalink) Old 04-24-2019, 06:41 PM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
So....there are these plastic inserts that go back into the plenum from the pcv. One on each side. Each one has 2 different O-rings. The O-rings were torn on one of the inserts causing the vacuum leak. Fixed that and cleared everything. No more check engine light.
rockinlespaul is offline  
post #8 of 19 (permalink) Old 04-25-2019, 06:41 PM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Well the cel came back again on my way to work. Same codes. A co-worker thinks it's the exhaust seeing that there is so much more air flow now. No leaks in the exhaust, I checked that.

I am completely stumped. I can't find what the problem seems to be. Same two codes...P2187 and P2189.
rockinlespaul is offline  
post #9 of 19 (permalink) Old 04-25-2019, 06:46 PM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Sorry, I forgot to mention that I did not find any vacuum leaks in the catch can system either. Below are the codes.

Is it ok to run it like this? I'm supposed to be getting it tuned in two weeks and I will be driving 3 hours to get to the tuner.
Attached Images
File Type: jpg IMG_20190425_121935_1556235869559.jpg (133.6 KB, 14 views)
File Type: jpg IMG_20190425_121945_1556235905037.jpg (142.1 KB, 12 views)
rockinlespaul is offline  
post #10 of 19 (permalink) Old 04-25-2019, 07:55 PM
Senior Member
 
ebg8gt's Avatar
 
Join Date: Jan 2017
Location: Mount Airy, MD
Posts: 569
You could try replacing the O2 sensor(s). Could be coincidental that they need to be replaced.

2009 PBM GT
Under the Knife Again
Wiseco Pistons, K1 Rods, Johnson Lifters, BLP Keep Hatin' PDS Cam, Roto-Fab, BLP Ported Intake and Throttle Body, Kooks 1-7/8 long tubes, XForce Varex Catback, ZL1 Converter, Camaro Trans Pan/Filter, GXP Brembos
Breyton GTS-AV Wheels, 6k HIDs, Holden Steering Wheel and Paddle Shifters, Eibach Springs, 35% Tint
Tuned by Day Tuning
ebg8gt is offline  
post #11 of 19 (permalink) Old 04-26-2019, 06:39 AM
Senior Member
 
PONY MAN's Avatar
 
Join Date: Mar 2010
Location: EARTH :-/
Posts: 4,358
Hard to imagine both oxygen sensors Bank 1 (P2187) and Bank 2 (P2189) failed simultaneously, but that's not to say such is impossible. Recommend rechecking everything prior to (before) the oxygen sensors. Would double check the installation of the K&N intake as well. Driving the car with the two lean codes should be fine for awhile and the engine control module will try to compensate/adjust for the difference. At this point, have not further suggestions and good luck resolving the issue.

#NEVER GIVE UP
#AUDACITY OF HOPE

"Rather not run the risk of offending anyone, so let me just go ahead and offend someone". -PONY MAN

"When you write the story of your life, don't let anyone else hold the pen". -UNKNOWN














PONY MAN is offline  
post #12 of 19 (permalink) Old 04-26-2019, 07:08 AM
Senior Member
 
ebg8gt's Avatar
 
Join Date: Jan 2017
Location: Mount Airy, MD
Posts: 569
Agreed, it would be odd for both of them to go out at the same time.

2009 PBM GT
Under the Knife Again
Wiseco Pistons, K1 Rods, Johnson Lifters, BLP Keep Hatin' PDS Cam, Roto-Fab, BLP Ported Intake and Throttle Body, Kooks 1-7/8 long tubes, XForce Varex Catback, ZL1 Converter, Camaro Trans Pan/Filter, GXP Brembos
Breyton GTS-AV Wheels, 6k HIDs, Holden Steering Wheel and Paddle Shifters, Eibach Springs, 35% Tint
Tuned by Day Tuning
ebg8gt is offline  
post #13 of 19 (permalink) Old 04-26-2019, 11:37 PM
Senior Member
 
L_Alvis's Avatar
 
Join Date: Aug 2013
Location: KY
Posts: 269
Garage
I'm going to say its a tune issue. Not sure on the sensitivity of the V6, but higher flowing intake and exhaust=need more fuel. The ECM is only going to self adjust the fuel trims so much until it eventually throws a lean code. If you've already rigorously checked for vacuum leaks, then just wait til you get it tuned and I'd be willing to bet that'd fix your problem.

[SIGPIC][/SIGPIC]
BTR Stage 2 Kooks LTs SLP Powerflo 3.27 Rear
6/4-pot Brembos Tein/PPV BMR Bars/Arms TSW Nurburgrings
L_Alvis is offline  
post #14 of 19 (permalink) Old 04-27-2019, 07:39 AM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
I'm beginning to think so too. That's what the main driveability guy at work is telling me also.

I'm a little concerned about driving 3 hours to get to the tuner, but it does drive just fine with no issues.

I guess when I go back to work next week, I will go over everything again and make sure there are no vacuum leaks and go from there. Appreciate your input, thank you!
rockinlespaul is offline  
post #15 of 19 (permalink) Old 05-04-2019, 07:09 AM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Quick update...

I scanned it again, and cleared codes early in the week and the cel stayed off for a bit longer this time. Like 3 days and I drove the **** out of it. Pulled in my driveway on the 3rd day and it came back on.

I cleared it again 2 days ago and so far so good again. I'm wondering if it's trying to relearn? Not sure but tomorrow is tune day so I should be good to go after that.

It's supposed to be nice this weekend so I'm going to put some new plugs in her today and clean it up.
rockinlespaul is offline  
post #16 of 19 (permalink) Old 05-05-2019, 04:14 PM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Installed new NGK laser iridium spark plugs and new plenum gaskets. While I was in there, I also changed the cabin filter which was nasty as hell. I also changed the oil again as well.

Took it to the tuner and he hooked it right up. It was definitely running lean at 25%. He also did a trans tune and that made a huge difference in shifts. Everything is sooooo much better now!
rockinlespaul is offline  
post #17 of 19 (permalink) Old 05-21-2019, 09:30 AM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Just wanted to post a update since it's been a few weeks....

The G8 is performing like a top! No issues whatsoever. It's like a completely different car after having it tuned. I'm talking night and day difference.

I totally smoked a Camaro last night and some kind of hot rodded Saturn last week. Huge shout out to Daniel Smuts, the guy who tuned her. Dan is a really nice down to earth kinda guy and he has tuned many G8's....V6 and V8 versions. He tunes other vehicles as well.

I know he went into the fuel trim tables and did a lot of adjustments to that. It was definitely running lean before the tune but now it's damn near perfect. Advanced the timing and also upped my idle from 600 to 700 which I like a lot better. He also adjusted the shift points for the transmission. You can really wind it out now.

I've never been so happy with a car before. I absolutely love driving this baby!

I appreciate all the help you guys have given me and I love the G8 community! Here's a few pictures of my car.... I named her Karma. 2009 Pontiac G8 in pacific slate metallic.

I got her all cleaned up over the weekend and tried some Maguire's hybrid ceramic wax. I like it! Major water beading and the pic shows the reflection factor. Not too shabby lol.

The pic next to the red G8 GT was at Dan's place. He was also tuning that car.
Attached Images
File Type: jpg IMG_20190518_135232_1558448561071.jpg (139.4 KB, 19 views)
File Type: jpg IMG_20190518_194530_1558448623536.jpg (129.7 KB, 17 views)
File Type: jpg Screenshot_20190506-104102_1558448837331.jpg (3.4 KB, 14 views)
File Type: jpg IMG_20190410_151026_1558449001471.jpg (131.5 KB, 17 views)
rockinlespaul is offline  
post #18 of 19 (permalink) Old 05-21-2019, 01:26 PM
Senior Member
 
PONY MAN's Avatar
 
Join Date: Mar 2010
Location: EARTH :-/
Posts: 4,358
Great you were able to resolve the various issues and didn't unnecessarily replace parts. Enjoy the new setup on the G8.

#NEVER GIVE UP
#AUDACITY OF HOPE

"Rather not run the risk of offending anyone, so let me just go ahead and offend someone". -PONY MAN

"When you write the story of your life, don't let anyone else hold the pen". -UNKNOWN














PONY MAN is offline  
post #19 of 19 (permalink) Old 05-27-2019, 09:17 AM Thread Starter
Member
 
rockinlespaul's Avatar
 
Join Date: Oct 2018
Posts: 92
Thanks Pony Man!
rockinlespaul is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
finally got around to doing my engine cover mod jtirwin27 Lounge 17 02-19-2015 01:17 AM
G8 slipped 3rd gear today--- CEL went on slyther83 Drivetrain Tech 7 02-21-2013 03:19 PM
Dreaded "R" Word RoflsupG8 Appearance / Detailing 16 05-07-2011 02:58 PM
Finally I got it!! Diffuser and CEL on the same day! WickedMom G8 GT Talk (V8) 13 07-30-2009 01:40 PM
After 4 month of research I finally got my new G8 GT ing_malopez G8 GT Talk (V8) 13 05-10-2009 06:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome