Voltage issue with check engine light - Pontiac G8 Forum: G8 Forums - G8Board.com
 
LinkBack Thread Tools
post #1 of 14 (permalink) Old 06-30-2016, 03:14 PM Thread Starter
Senior Member
 
LTUNA03's Avatar
 
Join Date: May 2009
Location: BAYONNE NEW JERSEY
Posts: 192
Voltage issue with check engine light

Yesturday I ran into a charging system problem,Like always when I start my car up I go into enginering mode my battery charge started at 82% within a bout 30 minutes it was down to 62% and the voltage read at idle at 11.0 volts when driving it went up to 12.9 volts.with that said then all of a sudden the check engine light came on and the reduce power light came on?I was able to scan for codes and found a P2105 for the throttle actuator circuit (TAC).Just a coincidence with low voltage from charging system.Don't know.The first thing I did was change the alternator with an O.E alternator assembly.the charging system was back to normal that problem was solved,but the P2105 code did not clear so "back into my pockets I go) needed to replace throttle body actuator assembly,cleared code's problem solved everything back to normal.I can't be to upset since the repair cost for this car for me has been very low.

Year:2008
color:ignition orange;interior black leather
option:comfort and sound;premium package
new:august 2008 original owner
mods:20%window tint,6k led headlights and led fog lights,X-pipe,k&n air filter,hawk hps front and rear brake pads with r1-concepts premium series brake rotors
slotted and crossed drilled:general g-max as-03 tires;dvd in both headrest from myron & davis;auto dimming mirror.
LTUNA03 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 07-01-2016, 08:31 AM
Senior Member
 
norton13's Avatar
 
Join Date: Mar 2012
Location: Toronto
Posts: 1,839
I have not had a problem with either car yet, other than the car door actuator & gas actuator on the V6. Passenger seat trim went south on the V6 used a tie problem solved.

[SIGPIC][/SIGPIC]K&N CAI, Pypes headers, Solo HFC's,Solo axle backs, Custom tune, FE3 Struts & Shocks, White line bushings & bearings, Rear Cradle inserts, Moog end links.Little lunati cam,SLP 25 %UDP, AC tensioner upgrade.15% tint.12" sub woofer with amp.Future upgrade Power slot rotors & posi quiet pads.


V6 Spectre CAI, Original Overkill tune,FE3 Struts & Shocks, White line bushings & bearings, BMR Rear Cradle inserts, Moog end links.12" sub woofer with amp.
norton13 is offline  
post #3 of 14 (permalink) Old 07-02-2016, 09:10 AM
Senior Member
 
94transamgt's Avatar
 
Join Date: Jan 2008
Location: Troy, Michigan
Posts: 231
Low voltage will cause a multitude of issues with these cars. Check your battery, connections and alternator.

2009 GT Liquid Red- Bridgestone RE 760's, Xenon H 11's, previous 2005 GTO owner. SOLD Now 17' Camaro SS
94transamgt is offline  
 
post #4 of 14 (permalink) Old 07-02-2016, 11:54 AM Thread Starter
Senior Member
 
LTUNA03's Avatar
 
Join Date: May 2009
Location: BAYONNE NEW JERSEY
Posts: 192
Update:thought we were fine with the repairs new alternator:new (tac)throttle actuator control assembly,but check engine light back on with fault code #p2176;unable to relearn (tac)throttle actuator control;code continuously sets after idle relearn is done.come's right back after car is restarted;going to give it one more shot to do (tac) relearn procedure;if that does not work;then its off to having it towed to the dealership;i installed o.e parts both alternator and throttle actuator,i know that the alternator is putting out 14.3 volts after replacement.what is the chance that it's a defective (tac) throttle actuator.

Year:2008
color:ignition orange;interior black leather
option:comfort and sound;premium package
new:august 2008 original owner
mods:20%window tint,6k led headlights and led fog lights,X-pipe,k&n air filter,hawk hps front and rear brake pads with r1-concepts premium series brake rotors
slotted and crossed drilled:general g-max as-03 tires;dvd in both headrest from myron & davis;auto dimming mirror.
LTUNA03 is offline  
post #5 of 14 (permalink) Old 07-02-2016, 12:36 PM
Senior Member
 
Join Date: Sep 2014
Posts: 355
Quote:
Originally Posted by LTUNA03 View Post
Update:thought we were fine with the repairs new alternator:new (tac)throttle actuator control assembly,but check engine light back on with fault code #p2176;unable to relearn (tac)throttle actuator control;code continuously sets after idle relearn is done.come's right back after car is restarted;going to give it one more shot to do (tac) relearn procedure;if that does not work;then its off to having it towed to the dealership;i installed o.e parts both alternator and throttle actuator,i know that the alternator is putting out 14.3 volts after replacement.what is the chance that it's a defective (tac) throttle actuator.
Where did you find the tac module? Didn't know they had them separately from the entire TB assy...

Sent from my Nexus 6 using Tapatalk
G8eraid is online now  
post #6 of 14 (permalink) Old 07-02-2016, 01:55 PM Thread Starter
Senior Member
 
LTUNA03's Avatar
 
Join Date: May 2009
Location: BAYONNE NEW JERSEY
Posts: 192
My bad; i was referring to throttle actuator circuit (tac) its the whole throttle body assembly

Year:2008
color:ignition orange;interior black leather
option:comfort and sound;premium package
new:august 2008 original owner
mods:20%window tint,6k led headlights and led fog lights,X-pipe,k&n air filter,hawk hps front and rear brake pads with r1-concepts premium series brake rotors
slotted and crossed drilled:general g-max as-03 tires;dvd in both headrest from myron & davis;auto dimming mirror.
LTUNA03 is offline  
post #7 of 14 (permalink) Old 07-02-2016, 03:15 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 4,096
Assuming you have the ability to view your throttle blade position on the engineering page (as I can), you should be able to watch the % value change. With the ignition in the run position, my GT goes from about 22% at idle, to 99% at WOT. For starters, maybe you could see if yours even wants to display numbers similar to that. This, to verify that the blade is at least moving correctly from idle to WOT. If OK, then it says to perform that learn procedure. Was it done as it is written in the service manual ? It says (after performing that learn procedure), to *then* reset the fault code. If it reset (that's good). If not, they pretty much say that the TB needs to be replaced. I find it hard to believe that a new TB was a dud from the manufacture. But things like that can happen. If you have to go that route, I hope the place you got that new one from will allow for a free exchange/replacement of same.
GOPHERIT is offline  
post #8 of 14 (permalink) Old 07-05-2016, 01:10 PM Thread Starter
Senior Member
 
LTUNA03's Avatar
 
Join Date: May 2009
Location: BAYONNE NEW JERSEY
Posts: 192
update was able to return the brand new o.e throttle body assembly for another new one,installed the new o.e throttle body assembly again performed relearn sequence.throtlle body did relearn.code cleared,but when the ignition key is cycled and restart the car the fault code P2176 comes back,tryed the relearn sequence 3 more time it does relearn but when the key is cycled to resart engine code's come back.it maybe time to go to dealer

Year:2008
color:ignition orange;interior black leather
option:comfort and sound;premium package
new:august 2008 original owner
mods:20%window tint,6k led headlights and led fog lights,X-pipe,k&n air filter,hawk hps front and rear brake pads with r1-concepts premium series brake rotors
slotted and crossed drilled:general g-max as-03 tires;dvd in both headrest from myron & davis;auto dimming mirror.
LTUNA03 is offline  
post #9 of 14 (permalink) Old 07-05-2016, 02:00 PM
The Mustang dude
 
5litrarag's Avatar
 
Join Date: Apr 2009
Location: So Cal
Posts: 1,321
OEM Battery? I just finally replaced the OEM in mine. Wasnt having any issues, but everything works better now. Car cranks faster, accelerates better, shifts better, lights dont dim when I pull all the window switches... everything is better now. Dont overlook the obvious.

95 Mustang GT convertible 347 stroker
95 Cobra coupe Rotrex supercharged

The new baby - 09 White Hot G8 GT
Tinted, badges deleted

5litrarag is offline  
post #10 of 14 (permalink) Old 07-05-2016, 02:08 PM Thread Starter
Senior Member
 
LTUNA03's Avatar
 
Join Date: May 2009
Location: BAYONNE NEW JERSEY
Posts: 192
yes oem battery;battery has been load tested state of health of battery is normal

Year:2008
color:ignition orange;interior black leather
option:comfort and sound;premium package
new:august 2008 original owner
mods:20%window tint,6k led headlights and led fog lights,X-pipe,k&n air filter,hawk hps front and rear brake pads with r1-concepts premium series brake rotors
slotted and crossed drilled:general g-max as-03 tires;dvd in both headrest from myron & davis;auto dimming mirror.
LTUNA03 is offline  
post #11 of 14 (permalink) Old 07-05-2016, 03:23 PM
The Mustang dude
 
5litrarag's Avatar
 
Join Date: Apr 2009
Location: So Cal
Posts: 1,321
Quote:
Originally Posted by LTUNA03 View Post
yes oem battery;battery has been load tested state of health of battery is normal
And its as old as the car?
You do realize they have a lifespan, right? They can start cars forever it seems, doesnt mean everything inside it works right.
If your car is as old as mine, its 7 yrs old and it has to be losing effectiveness by now.

95 Mustang GT convertible 347 stroker
95 Cobra coupe Rotrex supercharged

The new baby - 09 White Hot G8 GT
Tinted, badges deleted

5litrarag is offline  
post #12 of 14 (permalink) Old 07-10-2016, 08:56 AM Thread Starter
Senior Member
 
LTUNA03's Avatar
 
Join Date: May 2009
Location: BAYONNE NEW JERSEY
Posts: 192
update;car is at the delaer;installed new battery as a precaution even though the old battery still tested good;also disconnected all after market items;dvd in headrest;led light ballest and remote xm radio harness;then we started the throttle relearn protocol precedure and still fault code p2176 keeps resetting within 30 seconds of starting the car voltage jumps to 24volts and idle will not relearn;keep in mind that the throttle body's are new o.e parts were change twice the alternator is a o.e new part;the ecm is new;no fuses have blown;the dealership i have it at i have known them and service my car's there since 1986.i have a very very long relationship with them so i have full trust with them;the tech working on the car i have know him for the last 25 year and is the only tech who works on all my car's;when my car go in for service they don't get bounced around to different tech like some dealers do;he has been in contact with gm technical and has opened a (T.A.C)case which is technical ass't from gm;they have not been helpful to point us in a direction to start looking for a power spike;i am afraid that they may have to start pulling apart wire harnesses;i would not mind if gm technical would give some idea were to start;right now at a lost looking for help

Year:2008
color:ignition orange;interior black leather
option:comfort and sound;premium package
new:august 2008 original owner
mods:20%window tint,6k led headlights and led fog lights,X-pipe,k&n air filter,hawk hps front and rear brake pads with r1-concepts premium series brake rotors
slotted and crossed drilled:general g-max as-03 tires;dvd in both headrest from myron & davis;auto dimming mirror.
LTUNA03 is offline  
post #13 of 14 (permalink) Old 08-02-2016, 09:30 AM Thread Starter
Senior Member
 
LTUNA03's Avatar
 
Join Date: May 2009
Location: BAYONNE NEW JERSEY
Posts: 192
Update,finally was able to pick up my car on saturday;after spending about a month at the dealer good thing they gave me a loaner vehicle a 2016 chevy tahoe ltz very nice suv;recapping the engine through a fault code for the throttle body;throttle body was then replaced following the service procedure including the relearn process thats when the fun began,as the tech was performing the relearn procedure the car keeped throwing the fault code #p2176,the ignition circuit voltage would jump and stay at 24 volts;that circuit should only be at 12 volts.the car still had the original battery,the battery was load test several time and checked out good,even though it checked out good we replaced with new oe battery,retryed the relearning prodecure again still same issue of the fault code #p2176 setting about 30 seconds into the relearn procedure;the alternator was making a whinning type noise for a couple of day prior to the car going into the shop;we then replaced the alternator with a new oe alternator assembly the whinning noise was gone,now with a new battery and alternnator and throttle body assembly,tryed to perform the relearn procedure again,still after 30 seconds into the relearn procedure the fault code #p2176 sets and the ignition circuit voltage jumps to 24 volts,the tech then gets in contact with gm technical ass't to get some help after spend hours on a confrence call with about 4 engineers they then determin to replace the ecm,we then had to order a new ecm which took a couple of days,the new ecm arrived and then the tech installed the new ecm then proceded to program everything;thinking this would be it,as its being programed the same fault code came back #p2176.wtf this dealer is the exclusive repair shop for all the police"ppv"caprice in the area which include the new jersey state police and port authority and all the local police in the area;unfortunately it was bad timing that i am having this problem because the tech that has been woring on it was going on vacation;i have been a customer of this dealership for over 25 year and i know this tech very well he is one of the best tech at this dealership when people come in for service they always request him to service there car's. Maybe it was best that he was going on vaction because when he came back he would have a clear head,because that code#p2176 is kind of straight foward once the throttle body is replaced just relearn idle,now the tech came back from vacaction and had to remove the fuse box from under the hood and had to expose the main wire harness loom,now it then became a tedious task to now remove wire by wire to see what cirucit the voltage would finally drop to 12 volts,keep in mind that wire harness contains over 100 wires he had to go one by one;after going through them and tightening all the pin connector in the fuse box and the connector end into the ecm the voltage was steady at 12 volts;then proceded to relearn system in less than a minute the system was able to be relearned and no fault code,somewhere in the harnees between the fuse box under the hood and the main harness that goes to the ecm and into the car along the right side fender assembly that was the problem causing the voltage spike;they then called me to come and road test the car,which i did for about 125 miles the car runs like it did when it was new.i am just glad that i did not have to replace the under hood fuse box and complete wire harness;now had the car back for a couple of days and its running great;this was an unusual problem that the dealer and gm technical ass't haven't seen

Year:2008
color:ignition orange;interior black leather
option:comfort and sound;premium package
new:august 2008 original owner
mods:20%window tint,6k led headlights and led fog lights,X-pipe,k&n air filter,hawk hps front and rear brake pads with r1-concepts premium series brake rotors
slotted and crossed drilled:general g-max as-03 tires;dvd in both headrest from myron & davis;auto dimming mirror.
LTUNA03 is offline  
post #14 of 14 (permalink) Old 08-02-2016, 12:48 PM
The Mustang dude
 
5litrarag's Avatar
 
Join Date: Apr 2009
Location: So Cal
Posts: 1,321
Glad its fixed but god damn that was a hard pair of run on sentences to read and comprehend.

95 Mustang GT convertible 347 stroker
95 Cobra coupe Rotrex supercharged

The new baby - 09 White Hot G8 GT
Tinted, badges deleted

5litrarag is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome