Won't shift out of 3rd gear - Pontiac G8 Forum: G8 Forums - G8Board.com
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-11-2019, 03:45 PM Thread Starter
Junior Member
 
Join Date: Jan 2018
Posts: 17
Won't shift out of 3rd gear

I drove my G8 into work this morning. It won't seem to shift out of 3rd gear. When I'm in manual mode I can't downshift or shift up. The shift indicator never reflects anything but S3.

From a complete stop it takes off in first gear and seems to be shifting up to 3rd gear. When I'm driving it feels more like second gear.

I see an engine light on the top left side of my dashboard. I'll check my transmission fluid level and see if there is an error code that reveals anything.

Please advise.

Paul
Parker, Colorado

Paul
Parker, cO
2008 G8 GT
56belair is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-11-2019, 06:03 PM
Senior Member
 
Jova007200's Avatar
 
Join Date: Aug 2011
Location: Charlotte, NC
Posts: 1,515
Garage
The input/output speed sensor can be problematic when things get too hot. Clear the codes then go for a drive around the block and see if it goes away.

Obviously there will be a few codes stored. At least one will be a generic trouble code. I don't remember what it was when this came up for me; maybe U0700 or something like that. The other was U0716 (or similar). This was a while ago for me and I'm going from memory only. There was a third code as well.

It may go away and not come back when you clear the codes, but that doesn't mean the problem is fixed.

'09 PSM G8 GT - OPG Intake, DOD-Delete w/ Stage 1C 218/229 .600 Lift 117.5LSA, Kooks 1 7/8 Mids, Solo Axle-Back w/ X-Pipe, SuperPro Bushings (Front and Rear). BMR Sway Bars (Red)
Power: 400HP/392TQ


"If you want to criticize someone else's work, be sure that your own is in order first."

[SIGPIC][/SIGPIC]
Jova007200 is online now  
post #3 of 5 (permalink) Old 04-12-2019, 07:52 AM
Member
 
Join Date: Apr 2010
Posts: 76
had a similar problem after emissions check - CEL - code P0700

Quote:
Originally Posted by Jova007200 View Post
The input/output speed sensor can be problematic when things get too hot. Clear the codes then go for a drive around the block and see if it goes away.

Obviously there will be a few codes stored. At least one will be a generic trouble code. I don't remember what it was when this came up for me; maybe U0700 or something like that. The other was U0716 (or similar). This was a while ago for me and I'm going from memory only. There was a third code as well.

It may go away and not come back when you clear the codes, but that doesn't mean the problem is fixed.
This problem was actually caused by a faulty OBDII checking unit. During the initial attempt by the checker to hook up the unit a CEL light appeared on the DIC . Car failed emissions check and was called out as a 'transmission fail'. When I left the checking station the car was locked into S2 and would not shift up or down, nor would it shift manually. Stopped at a transmission place I deal with and they checked the code which said a main communication buss to TCM was not communicating. They reset the code and the car/transmission returned to normal. This was mid March and it has been fine since.

Another emission checking station retested the car and it passed and has been fine since. They, in fact, said the other checking station had caused the CEL because of faulty equipment. Of course you may have a different problem/cause, but I thought this might be helpful.

I since have bought an analyzer to carry with me - they are cheap - and it has already paid for itself on my 2009 Solstice GXP.

grandpop09
grandpop09 is offline  
 
post #4 of 5 (permalink) Old 04-12-2019, 08:03 AM
Senior Member
 
Jova007200's Avatar
 
Join Date: Aug 2011
Location: Charlotte, NC
Posts: 1,515
Garage
I'm confused, are you posting for the OP?

'09 PSM G8 GT - OPG Intake, DOD-Delete w/ Stage 1C 218/229 .600 Lift 117.5LSA, Kooks 1 7/8 Mids, Solo Axle-Back w/ X-Pipe, SuperPro Bushings (Front and Rear). BMR Sway Bars (Red)
Power: 400HP/392TQ


"If you want to criticize someone else's work, be sure that your own is in order first."

[SIGPIC][/SIGPIC]
Jova007200 is online now  
post #5 of 5 (permalink) Old 04-12-2019, 02:08 PM
Member
 
Join Date: Apr 2010
Posts: 76
Yes - for the OP's sake. Sorry for the confusion.

grandpop09
grandpop09 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
M6 3rd gear noise -is this a synchronizer problem? sand240 G8 GXP Talk (V8) 21 01-15-2010 07:37 AM
Holding 3rd Gear andrewv28 Drag Racing 11 11-06-2009 11:28 AM
3rd gear chirps.... jatrex17 Intake/Fuel Tech 6 09-28-2009 08:00 PM
2nd Gear Starts (3rd Gear too) Gavine G8 GT Talk (V8) 22 09-23-2008 08:00 PM
Dyno's - 3rd or 4th gear? GXPaycheck Tech Lounge 6 07-29-2008 12:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome