Key Stuck in Ignition / Car Stuck in Park - Pontiac G8 Forum: G8 Forums - G8Board.com
Tech Lounge First Mods / Basic Tech Questions

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 06-11-2018, 11:13 AM Thread Starter
Member
 
Join Date: Oct 2010
Location: Pittsburgh, PA
Posts: 81
Key Stuck in Ignition / Car Stuck in Park

Hi All,

I wanted to run this by everyone here to see what your thoughts were. I won't be by the car for a few hours but I figured I'd get some initial ideas before I started to look at this. When I attempted to leave for work this morning, I put the key in the ignition, turned it, saw the gauges start to sweep, turned to on and nothing. I tried to turn the key back to off to remove it but it was stuck. I could only get back to the accessory position but I had no power anywhere at this time. No dome lights, gauges dead, couldn't open the trunk, etc. I went back in my house for a few minutes and came back out to the garage and as I was walking up to the car all of the power was restored. I moved the key back to off and was able to remove it. I put it back in and was able to the start the car. I tested this a few times and all seemed OK until I went to leave and I couldn't move out of park. The shifter was just stuck. I tried this a few times as well but no luck. I eventually ran out of time so I just left in my wife's car and have been doing some reading online about possible cause - blown fuse, shift lock solenoid, etc.

This is a GT and I'll also note that I have the triple gauge stack with Speedhut gauges that I installed in the Spring of 2017 that have given me some problems off and on where they will randomly freak out and throw and assortment of errors - check engine, ABS fault, traction control, etc. that usually requires that I unplug the OBD2 plug and disconnect/reconnect the battery to clear. They are still installed and get power but I've had the OBD2 plug disconnected for a little while now just to see if I see those errors again so they're not actually displaying any data.

Anyone have any thoughts on what I should be checking when I get home? Thanks in advance.
ejm41 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-11-2018, 01:40 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 4,096
If at your last engine shutdown still had the radio playing an it shutdown when the drivers door was opened, that is good. If you turn on the ignition to position 1 (with the radio an AC fan shutdown), you *must* be able to hear the solenoid in the steering column click *each* time you depress the the gear shifter lockout button (which will/should *only* depress 1/2 way in). If not, you've got a problem there. Then verify that each time to press on the brake pedal, you hear the solenoid click (in the console). If OK (an with the brake pedal depressed), slowly pull in on the shifter button. At the 1/2 way point you must hear the column solenoid click followed by the button depressing all the way in (which would now allow you to move the shift lever to whatever position you desire). It would be interesting to know how all this works repeatably, to assist in digging deeper into the power circuit.
GOPHERIT is offline  
post #3 of 4 (permalink) Old 06-20-2018, 07:48 PM
Senior Member
 
Join Date: Feb 2009
Location: SW Ohio
Posts: 1,850
I'm kind of wondering about either a flaky battery or a flaky ground.

Gone but not forgotten: 2009 Pontiac G8 GT, White Hot, Premium, Sport. Tune is "Down Under" by Men At Work.
WhiteHotG8GT is offline  
 
post #4 of 4 (permalink) Old 06-20-2018, 09:35 PM Thread Starter
Member
 
Join Date: Oct 2010
Location: Pittsburgh, PA
Posts: 81
Thanks for the replies, guys. So here's what happened. I got home from work and checked it immediately - car started but was still stuck in park. I talked to my neighbor who's a car guy and he told me he had a similar problem at some point and said I should check the fuses, namely the ECM. I figured what the hell, so I checked a few under the hood - ECM, reverse lockout, and others I thought could be related. I pulled a few and didn't see any that were blown. I fired her up after that and tried to put into R - still stuck. Shut the car off and tried it again and, VOILA!, it shifted. At this point, my father stopped by with his multimeter because he thought it may be an alternator/battery issue. I started the car, hooked the meter up to the battery and started to see some really strange readings - 8-9 volts. This eventually went away and returned to normal but I thought it was extremely strange. I did replace my alternator 3 years ago with and OEM one after my car sat on a trickle charger over the winter. It was shot when I brought it out for the year. I also replaced the battery Spring of 2017. This make sense to anyone? I feel like this is related to all of the weird issues I have with the Speedhut gauges but I don't know exactly what it is. Maybe it is a ground.
ejm41 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome