Starter fuse keeps blowing - Pontiac G8 Forum: G8 Forums - G8Board.com
Tech Lounge First Mods / Basic Tech Questions

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 07-31-2018, 07:50 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 1
Starter fuse keeps blowing

So for the past week I would get in my car and it would crank up fine then I’d get where I’m going and it would be a short stop then my car wouldn’t do anything at all when I turn the key over. Now just recently I had to get it checked and anytime I turn the key now it burns the starter fuse up. Anybody know why this is?
Donald Gardner is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-31-2018, 08:05 PM
Senior Member
 
Join Date: Sep 2014
Posts: 355
Probably the starter. Had similar problem, cold starts were fine. Starting hot was hit or kiss, sometimes had to wait up to an hour or two for it to start... Ended up being the starter, heat from the exhaust manifolds sometimes deteriorates it faster.


Sent from my Pixel 2 XL using Tapatalk
G8eraid is offline  
post #3 of 3 (permalink) Old 10-20-2018, 01:42 PM
Member
 
Join Date: Sep 2017
Posts: 45
Check the wiring or like others said the starter could be faulty. Was it doing this before you changed it?
Nick.capalbo1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome