G8 trouble code list - Page 2 - Pontiac G8 Forum: G8 Forums - G8Board.com
Tech Lounge First Mods / Basic Tech Questions

Reply
 
LinkBack Thread Tools
post #21 of 40 (permalink) Old 01-11-2013, 12:56 PM
Senior Member
 
Join Date: Apr 2012
Location: FT Stewart GA
Posts: 498
CEL on again today. bank 1 sensor 2 lean/rich condition, bank 2 sensor 2 lean/rich condition.
f3racer is offline  
Sponsored Links
Advertisement
 
post #22 of 40 (permalink) Old 01-11-2013, 02:15 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 4,096
So, are the 2 codes you have now, 2 of the original 8 from awhile back, or different fault codes ? An if they are a repeat of before, are you sure that things like your radiator cooling fans are operating normally ?
GOPHERIT is offline  
post #23 of 40 (permalink) Old 01-16-2013, 04:26 PM
Senior Member
 
Join Date: Apr 2012
Location: FT Stewart GA
Posts: 498
Re: G8 trouble code list

Different code. Just one p0420 catalyst efficiency bank 1.

Sent from my DROID RAZR using AutoGuide.Com Free App

Last edited by f3racer; 01-17-2013 at 05:17 AM.
f3racer is offline  
 
post #24 of 40 (permalink) Old 01-16-2013, 08:18 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 4,096
We are dealing with a V8 here, correct. You say P0430 is bank 1, but I read it as bank 2. The V6 and V8 both use that code for the same problem. But on the V8, it is referring to the passenger side. On the V6 it would be the drivers side.
It seems that both sides would want to show this fault. Only having it on one side (assuming you don't have some type of exhaust leak), I'm leaning towards a weak downstream sensor here (at worst, a bad cat). Don't know how (into it) you are, for T/S your car, but if you reset the fault and it keeps coming back over an over, you might switch it with the same location on the drivers side to see if it flips to a P0420 code. If so, I think you would need a new HO2 sensor.
GOPHERIT is offline  
post #25 of 40 (permalink) Old 01-17-2013, 05:20 AM
Senior Member
 
Join Date: Apr 2012
Location: FT Stewart GA
Posts: 498
That was a typo it was 0420 bank 1. I have no cats and have done the o2 sensor spacer mod. The tool i used said it was the o2 sensor before the cat.
Ill swap the sensors and see what happens
Sent from my DROID RAZR using AutoGuide.Com Free App
f3racer is offline  
post #26 of 40 (permalink) Old 01-17-2013, 02:02 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 4,096
^^^ Well you've got me stumped on that post. Whether its P0420 (as corrected) or P0430, my read is that this code is from the down stream sensor (after the cat). Your read is the sensor (before) the cat. But I now read you have *no* cats in the exhaust, (amazing). I have no idea how down stream sensors would react, with the cats missing. Does this mean you have 2 sensors in a row in each exhaust pipe ? If the exhaust flow air/fuel mix is within the range that the upstream sensors like, you would think that the down stream sensors would be happy also. An if this is so, it still seems like one side, just isn't cycling its signal back to the ECM properly.
GOPHERIT is offline  
post #27 of 40 (permalink) Old 01-17-2013, 05:01 PM
Senior Member
 
Join Date: Apr 2012
Location: FT Stewart GA
Posts: 498
Re: G8 trouble code list

I have both o2 sensors just as stock. I gutted my cats and did the mod i found in this forum about using spark plug non foulers to cheat the cel. I got no cels dedicated to the cats being missing. I got the last huge set of cels due to the bad fuse. Now all of the sudden i have a p0420. The snap-on tool i used to check the cel and clear it said bank 1 sensor 1 but i know that wiring harness was ripped in half before sensor 2 and a denso replacement from gm was spliced in.
Sent from my DROID RAZR using AutoGuide.Com Free App
f3racer is offline  
post #28 of 40 (permalink) Old 01-17-2013, 06:50 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 4,096
OK I got it. You now have the equivalent of a straight pipe with the mumps in that location. Your sure, you don't have the position 1 and 2 sensors revered in their position on that side ? Since you had some wiring problems awhile back, your positive that repair is rock solid ? About the only quick way to verify that the correct sensors are going to the correct location, would be to verify the *cars* wire loom colors (not those attached to the sensors themselves), going to each sensor.
If conditions allow, you could check that the *forward* sensor is using the wire color pattern of BN/YE to A--- PU/WH to B--- GY/WH to C--- and PK/D-BU to D.
The *rear* sensor colors should be, BN/WH to A--- PU/WH to B--- BN to C--- PK/D-BU to D. Course, if you know its right, forget about it.
GOPHERIT is offline  
post #29 of 40 (permalink) Old 01-18-2013, 05:11 PM
Senior Member
 
Join Date: Apr 2012
Location: FT Stewart GA
Posts: 498
Re: G8 trouble code list

100% sure about the location but only 80% sure about the repair. Ill look it over

Sent from my DROID RAZR using AutoGuide.Com Free App
f3racer is offline  
post #30 of 40 (permalink) Old 10-14-2014, 07:30 PM
OGOC MEMBER
 
cutlassguy's Avatar
 
Join Date: Aug 2014
Location: Orangeville, Ontario, Canada
Posts: 320
Quote:
Originally Posted by WhiteHotG8GT View Post
Just found a trouble code list for the G8 at

http://www.wikiauto.com/Pontiac-G8-2...Code-List.ashx
Hey guys, I can't seem to open up this link on my computer, it times out and then says web page is no longer available. Anyone else have this problem?
Thanks
Eric
cutlassguy is offline  
post #31 of 40 (permalink) Old 10-14-2014, 09:10 PM
Senior Member
 
Join Date: Jan 2009
Location: SW Ohio
Posts: 791
Does not work for me either

[SIGPIC][/SIGPIC]
Rotohack 102 intake - 102 MAF -TPIS 102 TB - TVS1900 ported 8 rib 2.5" front + OD rear cog - RCR ported heads - Lunati 219/231 113+1
Kooks 1 7/8 LT - Solo 3" CB - 3.27 diff w WaveTrac - MT DRs + M&H FRs on Weld RT-S - CTS-V fuel w Vaporworx - Alkycontrol meth M15 + M10 - RCR tune
Old [email protected] 1.51 60'
New ? @ ?
TooManyHobbies is offline  
post #32 of 40 (permalink) Old 10-15-2014, 01:33 AM
OGOC MEMBER
 
cutlassguy's Avatar
 
Join Date: Aug 2014
Location: Orangeville, Ontario, Canada
Posts: 320
If someone has the list maybe they could post them here for other members that can't open the link. Just a thought.
Thanks
Eric
cutlassguy is offline  
post #33 of 40 (permalink) Old 03-15-2015, 10:11 PM
Junior Member
 
Join Date: Feb 2015
Posts: 2
Check engine light w/two codes

Codes: p0157 p2272

Seems pretty clear I have an O2 sensor or some related problem I just need more info on how to test.

I have cleared them once and the came right back anyone have more info?

Doug
08 GT
DougsG8GT is offline  
post #34 of 40 (permalink) Old 03-16-2015, 10:10 AM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 4,096
It says that your passenger side downstream (after cat sensor) is sensing a constant lean condition. This may be due to a weak heater within that sensor. Tough to T/S a sensor. You or somebody could reverse those downstream sensors to see if the faults follow. If the codes change to P0137 an P2270, you would then know that the sensor (now located on the drivers side) is faulty. Or (take a small chance) an just replace the one on the passenger side (if you only want to get under the car once).
GOPHERIT is offline  
post #35 of 40 (permalink) Old 03-16-2015, 08:15 PM
Junior Member
 
Join Date: Feb 2015
Posts: 2
@GOPHERIT

Thanks. That makes perfect sense. I will work on it tomorrow and report back!

Thanks again
DougsG8GT is offline  
post #36 of 40 (permalink) Old 10-07-2015, 09:28 PM
Senior Member
 
PaFromFL's Avatar
 
Join Date: Jan 2009
Posts: 491
After my check engine light came on, I tried reading the error codes with a cheap Harbor Freight Autel code reader. The "codes" were $7EA and $7E8, which are not in the correct format. Google turned up similar "codes" for a variety of GM cars. Someone claimed it was associated with a bad cat. My G8 has 4689 miles and has spent an abnormal amount of time idling in the driveway. I use premium non-ethanol gas. Any ideas?

2009 G8 GT, premium, sport, sport red metallic
Roto-Fab CAI
MagnaFlow 16887 Street Series cat-back
Superchips Cortex: Rotofab 91 Octane, 25% TM, AFM off
and splash guards (that look better than dirt)
PaFromFL is offline  
post #37 of 40 (permalink) Old 10-07-2015, 10:08 PM
Senior Member
 
Join Date: Jan 2010
Location: Fountain Valley California
Posts: 4,096
Those codes don't do a thing for me. You best get a readback from a code reader, that displays the codes in the P format. For example P1157 or P0174 etc.
GOPHERIT is offline  
post #38 of 40 (permalink) Old 11-27-2015, 09:22 PM
Senior Member
 
PaFromFL's Avatar
 
Join Date: Jan 2009
Posts: 491
I finally took my G8 for a half hour drive, and check engine light went away. I suspect the oxygen sensors got dirty during the long idling sessions.

2009 G8 GT, premium, sport, sport red metallic
Roto-Fab CAI
MagnaFlow 16887 Street Series cat-back
Superchips Cortex: Rotofab 91 Octane, 25% TM, AFM off
and splash guards (that look better than dirt)
PaFromFL is offline  
post #39 of 40 (permalink) Old 11-28-2015, 06:54 AM
Junior Member
 
Join Date: Jul 2015
Posts: 21
When I first got my G8 back in 2009 I had that thing in every week it seems because of the check engine light. They just about changed every sensor in the thing until they realized every time the light was on the gas cap was loose. There was a direct correlation between my wife getting gas and the light coming on... apparently tightening the gas cap was lost on her!
spy007 is offline  
post #40 of 40 (permalink) Old 01-19-2017, 12:18 PM
Junior Member
 
Join Date: Jan 2017
Posts: 1
Unhappy 2009 pontiac g8

HELP HELP HELP!
My 2009 pontiac g8 is throwing a code poooo9 i took to the dealership and they told me it was a timing chain problem, i spent 2,500 for all new timing chains ....serpentine belt.... all new plugs and it needed a front left motor mount didn't have it back 5 days and threw the same code again. now they are saying that it needs a crank shaft and they want 4,000 for the work. i had a good friend that works for harley davidson go with me to the dealership to see it for my own eyes and they are saying its needs to be 3 1/2'' and its rotated 2'' they put a new crank shaft sensor in and its still throwing the same code.... i have also noticed that ever since they have done all the work on it with the timing chains that when the car is running in park or in gear the rpms rev and fluctuate. I need help please any suggestions would be greatly appreciated. Do they have the timimg off or is it really needing a whole need crank shaft
hollywood is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome