Passenger side headlamp not working - Pontiac G8 Forum: G8 Forums - G8Board.com
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-23-2019, 09:12 AM Thread Starter
Senior Member
 
zm1040's Avatar
 
Join Date: Oct 2013
Location: Central Texas
Posts: 464
Passenger side headlamp not working

Hello,

My passenger low beam is not working. It's been out for about three weeks and I finally got stopped the other night, so it's time to get to the bottom of this.

I am using a TRS relay harness (three-four years old) and a new (four months old) Diode Dynamics bulb and ballast/igniter kit.
I have tested all circuits going into and out of the relays. Both relays themselves are good. The "to ballast" is getting 12v, but when plugged in to this ballast or two cheap ass DDM tuning ballasts, they all fail to fire. Plugging the 12v signal from the headlamp directly into any ballast makes them fire. So even though the positive from the relay is getting power, it will not ignite.

Any ideas? I don't know where any wire or anything would be pinched and causing a loss of current.

Thanks!
Zach

2009.5 GT, SRM Premium and Sport Packages
Show -
- Morimoto LED projector fog assemblies
- Spec-D LED tail light assemblies
- VG shark fin antenna
- Drag DR-64 20x9
Go -
- Rotofab CAI
- Kooks mids, mid-pipe delete with H, GXP mufflers
- Pat G. tuned
Ride -
- King Springs standard height/PPV Severe Duty
shocks/struts
- BMR poly rear cradle bushing inserts, sway bars, and strut tower brace


zm1040 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G8 Forum: G8 Forums - G8Board.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Passenger side heated seat not working BarnesGN Tech Lounge 8 03-12-2019 06:32 AM
Radiator fan passenger side not working on low speed? dgeminix Tech Lounge 3 03-29-2016 09:23 AM
Passenger-side side skirt part number mpneill Appearance / Detailing 7 05-15-2012 07:56 PM
Passenger side headlamp complete Derek98z Parts for Sale Archive 4 02-28-2011 11:02 AM
WTB: GT right side Tail. (passenger side) StraightG8 Wanted to Buy / Trade 0 06-14-2010 11:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome