Pontiac G8 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Just found the forum and am new sorry if I'm not posting right or in the right spot, and I'm not very knowledgeable with cars/engines.
I've had a 2008 base model for about 2 1/2 yrs it's just under 150,000 now.
2 weeks ago it started kicking into "safety mode" when accelerating (it didn't happen every time driving) & In safe mode it was running, shifting, and sounding extremely rough. I also felt like it was louder when not in safe mode now than prior to the issue.

Took to my mechanic it was giving codes pointing to throttle body and sensors ect. So I had him put a new throttle body on he said he took it down the road and back fine. Within a mile after I picked it up it was back in safety mode so I took it back and took him for a drive with his computer to read codes. This time right away he was saying he didn't like the sound and that is was still throwing throttle related codes but also a new transmission code which was a way bigger deal. He has the car now but seemed really confused about the whole thing including safety mode when throttle body didn't fix it which has me worrying alot. Has anyone had transmission and safety mode issues at the same time or is that just coincidence?
 

·
Premium Member
Joined
·
4,652 Posts
There stands a great chance both issues are attributed to the throttle body. What were the original check engine codes? What are the current check engine codes? What brand of throttle body was used as a replacement?
 
1 - 2 of 2 Posts
Top