Pontiac G8 Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1,842 Posts
Discussion Starter #1 (Edited)
My car is finally going to 100,000 km's(62,000 miles)this weekend. Car still runs like a champ. Looks almost brand new & runs great. I know other people probably have way more km's (miles) than I do. How is your V6 holding up.
 

·
Superior Surveyor
Joined
·
244 Posts
My car is finally going to 100,000 km's(62,000 miles)this weekend. Car still runs like a champ. Looks almost brand new & runs great. I know other people probably have way more km's (miles) than I do. Hw is your V6 holding up.
I am right behind you ! 98,600! Only thing that has failed is the strut mounts and LCA's! Got a few maintenance things done here and there (Diff/Tran fluid changes), but runs great!
 

·
OGOC member
Joined
·
58 Posts
Ditto - strut mounts and LCA's- now at 147,000 km - My check engine light comes on occasionally and briefly- code relates to valve timing - Still enjoying the car every day!
 

·
Registered
Joined
·
1,842 Posts
Discussion Starter #4
My LCA' s where done before I bought it.FE3 Struts & Shocks White line bushings, bearings, BMR Rear Cradle inserts, Moog end links where done last year. Other than the driver door actuator, passenger seat trim zip tie fix & actuator on the fuel door. Car has been pretty good.The fuel door I have not even bothered with the it. The suspension was still okay but I wanted to stiffen it up.
 

·
Registered
Joined
·
1,917 Posts
At 169,988km tonight when I parked her.
Runs great, looks great, though the stinkin 401 is taking its toll on it.
Feels like it needs brakes, get the suspension looked at, love to get a set of 19 inch GT rims for it otherwise....stinkin 401....
 

·
Registered
Joined
·
1,842 Posts
Discussion Starter #6
I am right behind you ! 98,600! Only thing that has failed is the strut mounts and LCA's! Got a few maintenance things done here and there (Diff/Tran fluid changes), but runs great!
I have not done that that yet trans & diff fluid I will change it at 120,000 km's.
My GT still has not hit 75,000 km's yet.
 

·
Registered
Joined
·
1,842 Posts
Discussion Starter #7
At 169,988km tonight when I parked her.
Runs great, looks great, though the stinkin 401 is taking its toll on it.
Feels like it needs brakes, get the suspension looked at, love to get a set of 19 inch GT rims for it otherwise....stinkin 401....
You have not had a problem with your timing chain yet. I am doing 8000 km's oil intervals now I might bring them down to 6 or 7000 km,s
 

·
Registered
Joined
·
1,917 Posts
No. Can't worry about those things, start it, drive it, deal with whatever happens.
But as you say regular maintenance is the key, I'm off this week will let my son take it into the GM dealership he works at and change oil take a look see at everything, starting to shudder under heavy braking so probably looking at getting those done.
 

·
Superior Surveyor
Joined
·
244 Posts
No. Can't worry about those things, start it, drive it, deal with whatever happens.
But as you say regular maintenance is the key, I'm off this week will let my son take it into the GM dealership he works at and change oil take a look see at everything, starting to shudder under heavy braking so probably looking at getting those done.
If you replace brakes (Provided thats the cause) let me know what you end up getting. I am in the market myself.
 

·
OGOC Member
Joined
·
2,602 Posts
Im at 169,000 kms. It runs better now than ever.
 

·
Registered
Joined
·
1,842 Posts
Discussion Starter #11

·
OGOC Member
Joined
·
2,602 Posts

·
Registered
Joined
·
1,842 Posts
Discussion Starter #13

·
OGOC Member
Joined
·
2,602 Posts
Anything new on the V6 tune with will?
Not since the fall,Last thing was the larger throttle body.
We are researching a couple of things.
Just the cost factor at the moment. Have some home maintenance to do.
Im hopefully going to paint my rims before Lakeview . I have a copule things in mind for them.
 

·
Registered
Joined
·
140 Posts
198,500 miles and still drives like the day it drove off the lot.

Absolutely no issues at all, nor has it ever had any issues. Never had a check engine light on.

No major work has ever been done. Only the regular maintenance (oil changes, tune ups, coolant flush..), although I did just replace the strut mount lat summer.

original timing chain.
 

·
Registered
Joined
·
161 Posts
At 169,988km tonight when I parked her.
Runs great, looks great, though the stinkin 401 is taking its toll on it.
Feels like it needs brakes, get the suspension looked at, love to get a set of 19 inch GT rims for it otherwise....stinkin 401....

Yeah the 401 is not kind to any car. I know your pain lol


In response to the original poster, sitting at about 149,100km right now, probably about half-to-three quarters of the way through its second set of brakes, a little salty, needs a wash, and I've been trying to track down a phantom coolant leak that I can't see but I could smell, but I think thanks to some dye I've finally narrowed it down to being the pressure cap. Waiting for one to come in...no dealership in Canada had it so it's being shipped in from Tenessee. Go figure. Also, the driver's side dashboard knee panel started falling off recently and I had to fight it to get it back together. It is now reasonably secure. Mechanically sound in all other respects.
 

·
Registered
Joined
·
1,917 Posts
If you replace brakes (Provided thats the cause) let me know what you end up getting. I am in the market myself.
Will go with AC Delco parts thru dealership, use my kids discount.
Had the car in today, brakes had lots of life left in them, had them cleaned up and was told: Gee Dad....maybe if you slowed down.....

Oil changed today at 170,006km with Mobil 1 5W30 synthetic, oil had 7500km on, it was good for another 2500km according to the car but I had time today.

Had tranny fluid level checked, had to replace the drain plug that was siezed.
Replaced 2 burned out marker lights.
Good to go for another 7500km.
Next major expence new Michelin's probably A/S'3.
 

·
Registered
Joined
·
1,917 Posts
Yeah the 401 is not kind to any car. I know your pain lol


In response to the original poster, sitting at about 149,100km right now, probably about half-to-three quarters of the way through its second set of brakes, a little salty, needs a wash, and I've been trying to track down a phantom coolant leak that I can't see but I could smell, but I think thanks to some dye I've finally narrowed it down to being the pressure cap. Waiting for one to come in...no dealership in Canada had it so it's being shipped in from Tenessee. Go figure. Also, the driver's side dashboard knee panel started falling off recently and I had to fight it to get it back together. It is now reasonably secure. Mechanically sound in all other respects.
I had the same problem with an off/on coolant leak, could smell it but couldn't see it. Once and awhile found a puddle of coolant on garage floor.
Check right rear of engine where coolant lines go over valve cover, my lines rubbed against the valve cover causing a pin hole leak in one line.
New lines have a bend in them routing off the valve cover.
If problem persists after changing pressure cap check this.
Good luck
 

·
Registered
Joined
·
161 Posts
I had the same problem with an off/on coolant leak, could smell it but couldn't see it. Once and awhile found a puddle of coolant on garage floor.
Check right rear of engine where coolant lines go over valve cover, my lines rubbed against the valve cover causing a pin hole leak in one line.
New lines have a bend in them routing off the valve cover.
If problem persists after changing pressure cap check this.
Good luck

I will, thanks. So far it seems like the cap is doing its job. One day I did find 2 drips but they were under where the front of the engine would be. I had remembered your post about the friction damaging those hoses and so I put UV dye in and checked them first (I think maybe mine are a revised version?) and then all around the engine and the engine compartment from both above and below (using a proper UV light and all) - nothing.

The only reason I found what I found around the radiator cap is because I had spilled some dye when I was putting it in (then I tried to rinse it away, forgetting what the dye was for, and made a huuuuuge green lake in my work parking lot) and later on I took it all to a wash bay and completely rinsed it down. Two days later, I was still smelling coolant but not seeing anything anywhere, so I did another UV light search and found nothing again...but then I noticed that around the cap (where I had been careful to completely hose away all traces of the dye) were more traces of the dye itself with no coolant left (had all burnt off, hence the odour I'm sure) leaving some crusty red stains.

I ordered a new cap (had to come from Tennessee...not one dealership in Canada had it, per the parts guy at Leggat Chev in Burlington) and when I put it on, I noticed that both the rubber seals on the old one looked very flattened out or squished; and also, there was a large amount of coolant present in the outer shell of the cap where it shouldn't ever get (the spinning part that threads onto the water outlet, but is above where the seals are so it never sees coolant). It seems reasonable that a radiator cap would start to crap out after 7 years...I seem to recall the old-fashioned ones would need replacing periodically, so why not these apparently rare, fancy-pants ones as well? LOL

It's been a few days now and I'm not noticing anything so far. There's no odour of coolant (I could smell it when I was exiting the driver's door, didn't even have to be close) unless I get right up near to coolant components and put my nose within inches of them (i.e. hoses, pressure cap, the overflow tank) and even at that range it is extremely faint; so, I'm THINKING I got it right. I'm going to go another few weeks and see how it goes. Then I have to decide if I want to flush the system for the second time within 15,000km (wish this happened BEFORE I had the coolant flushed) to get the dye out.
 
1 - 19 of 19 Posts
Top