Pontiac G8 Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
753 Posts
Discussion Starter #1
Just finished up last night and went out to do a little final tweaking and i hear a little bit of lifter tick. It comes and goes. My oil pressure is good, so i'm thinking they still might be a little loose. The reason i ask is because this is the first time i have dealt with these lifters and want to make sure.


Thanks.
 

·
Registered
Joined
·
304 Posts
Which lifters did you get?
 

·
Registered
Joined
·
753 Posts
Discussion Starter #3
Lunati High speed link lifters.

I heard they are kind of finiky, so i just went another 1/8 turn and seemed to help. The preload on these are 0.010-0.020. I had them set around 0.010.
 

·
Registered
Joined
·
753 Posts
Discussion Starter #4
Running wayyyyy rich as well,but thats expected.
 

·
Registered
Joined
·
753 Posts
Discussion Starter #5

·
Registered
Joined
·
753 Posts
Discussion Starter #6
Ok i just fired it up again a few minutes ago and all was quiet, but as it warmed up it kept getting louder. After 5 minutes or so i shut it down. Use of synthetic oil??? Lifters too tight...I'm at a loss here and crunch time is Tuesday since i start my new job then. If there is anybody in the Houston area I will pay to check it out to see what I'm doing wrong.....

It has to be something that i'm not doing right.
 

·
G8 GT GUY
Joined
·
745 Posts
Pushrods too short is my guess. What size you use?


When you said you did another 1/8 turn, what do you mean, aren't the rockers fully torqued? Pushrods determine preload is my understanding.

Edit: just saw you have adjustable rockers..
 

·
Registered
Joined
·
753 Posts
Discussion Starter #8
Pushrods too short is my guess. What size you use?
7.100

When i recieved my initial setup, it came with 7.400. These were noooo way the correct length. I was compressing the spring before the shaft rockers even seated. So i got a rod checker, set my adjustable rockers out .050( one turn out from rod cup seating) as my starting point.The rockers are comp cams shaft rockers, the heavy duty ones. With these heads you cant really do the wiggle/roll test while you are finding you length, so I would remove the rocker and rod, adjust out the rod until i was less than an 1/8 turn from pushrod contact (from the .050 initial rocker setting). When i was that close, I would GENTLY start turning the adjuster in while GENTLY rocking the arm up and down. As soon as i felt no play in the rocker, and the adjuster had the slightest tension at all, I stopped. I then removed the rocker, used a sharpie to coat the valve stem, reinstalled the rod checker and rocker and did a few rotations. The wipe pattern was just north of center so i measured my length with a set of dial calipers and it came out to 6.90.
 

·
Registered
Joined
·
753 Posts
Discussion Starter #9

·
Registered
Joined
·
753 Posts
Discussion Starter #10 (Edited)
Here is a pic of the run in marks....

To me it looks correct.

No clearence issues.. I even checked valve stem to rocker shaft hights. GRRRRRRR
 

Attachments

·
Registered
Joined
·
753 Posts
Discussion Starter #11
Ok here's something but i need someone who knows these rockers.

On the stockers, the first rocker is offset then straight etc...etc

On the comps it is the oppsite???
 

·
Registered
Joined
·
753 Posts
Discussion Starter #12
One thing i have found is that the PRW rods are .009 thicker than the manley's.And it looks like they don't sit in the rocker cup as well because the center of the PRW'S have no run in on them but the outer edges do, same with the rocker cups.
 

·
G8 GT GUY
Joined
·
745 Posts
I'm not familiar with those rockers, but you'd think they should fit correctly..maybe someone else will chime in. It seems to me that it would be a problem if all the pressure is only being applied to such a small surface area..how would an oil film hold up under those circumstances
 

·
Registered
Joined
·
753 Posts
Discussion Starter #14
I'm not familiar with those rockers, but you'd think they should fit correctly..maybe someone else will chime in. It seems to me that it would be a problem if all the pressure is only being applied to such a small surface area..how would an oil film hold up under those circumstances


Ditto because im at a total loss. The only thing i have not tried was to run heavier oil.

Everything else adds up properly. Geometry looks good, I have it set to about .015 now, wear patterns on the valve stem looks good. It even idles smooth and you cane see from the video. It's running pig rich because i have not started tuning but all in all I don't get it. I have never had this much trouble with ANY valvetrain.:cursin:
 

·
Registered
Joined
·
1,050 Posts
You able to run the stock rocker setup and see if it changes?


Sent from my fresh lubed iPhone
 

·
Registered
Joined
·
753 Posts
Discussion Starter #16
Not too sure but that will be my next step. I never checked nor did i think i need to but i think the base circle is larger on this aftermarket, but I think it's close enough because when i measuerd the difference off the seat with the new cam 7.400 rods and stockers it was right around .300.
 

·
Registered
Joined
·
753 Posts
Discussion Starter #17
I'm running 5-30 full synthetic and am wondering what if any heavier oil can be safely run in these engines.....worth a shot??? I'm wondering if maybe it's just running straight through.BUUUT my oil pressure at 800 rpm is 45 or so.
 

·
Registered
Joined
·
1,050 Posts
I run 15-50 at track events. Seems to be just fine. Helps with oil temps and stable pressure. I ran 15-50 in the Z06 for 95,000 miles. Our viper runs it also. No issues. I would swap your stock rockers back on and see what happens. Maybe you do have the wrong pushrods.


Sent from my fresh lubed iPhone
 

·
Registered
Joined
·
753 Posts
Discussion Starter #19
That's about all i can think it comes down to. I have done plenty builds in the past and this is the first time i have ever had this much trouble with a valvetrain. Either that or i got a bum set of $700.00 lifters.
 

·
Registered
Joined
·
753 Posts
Discussion Starter #20
Just got off the phone with lunati and learned a few things.

I was told that the springs and lifter combo were a good match, I also sent the pic of my wear mark, they said by the look of it, i was spot on. I told him i was running .025..1/2 turn. BUT he informed me that since i have aluminum block and heads i can lose up to .070 due to expansion and will be safe almost going another full turn and still keep my geometry, and the oil should be okay. It kind of makes sense because before i tore it back apart yesterday, when i fired it up it was pretty quiet then got louder after 5 minutes.

I asked him if he was absolutely sure if i can go that far and he said yes.

Here's hoping.
 
1 - 20 of 35 Posts
Top