Pontiac G8 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
361 Posts
Discussion Starter #1
Was wondering if anyone else had this problem, or maybe someone has some advice. Sorry for the long thread...

Im in the middle of doing a cam and LSA install/swap on my 09.5 GXP M6. Have a killerchiller but will be updating to a Frostbite chiller(about to order it). So I decided to remove the ac condenser during the cam swap(also have a new spare condenser I wanted to install), the top suction line fitting came off fairly easily. Although the entire bolt+nut unscrewed from the condenser, instead of just the nut. I noticed some corrosion on the smooth part of that bolt once it was off.

The bottom liquid line fitting nut came off ok. But the fitting itself will not budge, it looks like theres so much corrosion between the bolt/fitting that its basically welded on. I tried soaking it in PB Blaster and scraping away some of the corrosion with a small flat head. After several hrs I got a couple mm's of corrosion out but didnt help a bit. I have tried prying it off 10 different ways, heated the bolt a bit, grabbed it with pliers etc... Also tried attaching a very small socket to the end of the bolt to break it loose, wont budge.

Then I decided to remove the entire liquid line running to the expansion valve along with the condenser thinking it would make things easier. I removed the lines from the exp. valve and the high side hose clamps the low side onto it with a U. But I cant slide the low side line out of the U its too thick!

This is on a 2009.5 GXP M6 125k miles
 

·
Registered
Joined
·
361 Posts
Discussion Starter #2
Ok so the fitting was definitely completely corroded! I tried using two bolts and lock them onto the stud in order to twist it, no go. Then I finally decided to tighten the original bolt as tight as I could get it and the stud snapped a few mm past the nut which finally let the fitting come off... Dont even want to say how long it took to get this damn fitting off!!!

If anyone has any idea why this happened I would like to know, cant imagine Im the only one with this problem?
Here are some pics, enjoy

IMG_20181005_011116.jpg

IMG_20181005_010740.jpg

IMG_20181005_010753.jpg

IMG_20181005_011022.jpg

IMG_20181005_011150.jpg
 
1 - 2 of 2 Posts
Top