Pontiac G8 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
Red LCD DIC split screen started having this problem on my 2009 with 28,000 miles. Ive read the previous posts on this subject however none of them give a final outcome or resolution for the repair. Battery was changed last year and no other issues are present. All help will be appreciated Thanks
 

·
Registered
Joined
·
4,411 Posts
Exactly how is the screen malfunctioning i.e. garbled text, blank, dim, etc.? Probably irrelevant, but what brand of battery are you using? Have you checked the battery post connections and the battery ground bolt? https://www.g8board.com/threads/battery-ground-bolt-read-and-check-yours.224746/ In the past, it has caused a variety of issues for quite a few forum members even though you stated no others issues are present.
 

·
Registered
Joined
·
4,411 Posts
Failed to mention it may be beneficial to contact Chris at White Automotive and Media Services if nothing pans out here on the forum. Good luck
 

·
Registered
Joined
·
61 Posts
Discussion Starter #4
The top third of the screen will show the upper part of vehicle speed , when showing odometer it reads complete in the upper part of the screen but at the bottom it duplicates it. when in engineering mode only shows 3 top lines. I will check the ground bolt but the car has never been driven in the winter and rarely in the rain. Thanks for the thoughts. Bill
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
2 Participants
G8MAN1
Pontiac G8 Forum
A community for Pontiac G8 owners and enthusiasts, for all the information on your Pontiac G8 sedan, G8 GT, G8 V6, and G8 GXP. Discuss performance, tech, engine specs, body kits and more!
Full Forum Listing
Top