Pontiac G8 Forum banner

1 - 20 of 64 Posts

·
Registered
Joined
·
516 Posts
Discussion Starter #1
So Before anyone replys with what I know they will reply with. I know....and you dont have to tell me that this is garbage and wont do a thing, If it only costs $69 for 30 HP everyone would have them, I would never install that on my car etc. etc. etc.

But the honest to goodness truth is I got this as a Christmas gift without my prior knowledge. So I am going to show the curtousy to the gift giver and install it and go from there. If by chance it does something great if not I'll have him return it. So this is more of an FYI thread and I'll let you know what happens and how it performs.

Just for kicks I emailed CS and they said this is good for 30-35 HP and said its programed vehicle and motor specific. It says I dont need to run 89 or premium gas. From what I understand its just a $.50 resister in a fancy metal case that tricks the computer so it runs a leaner A:F. So when I get a chance to install I will let you all know what happens and give you my inpressions.
 

·
Premium Member
Joined
·
2,191 Posts
Is it the one you told me about earlier this year?I'll keep a eye on this thread.
 

·
Registered
Joined
·
864 Posts
:popcorn2:
 

·
Registered
Joined
·
516 Posts
Discussion Starter #6
Is it the one you told me about earlier this year?I'll keep a eye on this thread.
Its actually different. The one I was scoping out before was the VP12 Chip from Volo Performance. That is not an IAT one. Hooks up to your OBD II port. I have read mixed reviews on both so who knows. The technology behind the Volo Performance one seems more convincing to me but I will give the GForce one a whirl since I will be getting it in the mail shortly.

In regards to the Gforce I have read a few very possitive reviews from WRX owners. They actually dynoed real gains but thats apples to oranges comparison with ours.

Got an email back from the sales manager and he said he is going to look up the dyno / performance testing info and send it to me. Very sceptical that there is anything but I'll give him the opportunity to supply it. I have been getting quick responses and good CS thus far so thats a plus.
 

·
Registered
Joined
·
516 Posts
Discussion Starter #7
Do a dyno before and after.
Its not likely that I will have the opportunity to do that but it would be a great comparison. I will be taking her back to the track in the spring and the track doesnt lie. I'll compare the adjusted times and go from there. Its not a great comparison to begin with since I'll have a partial intake and mufflers since I ran in June but it will be something.

I dont believe it will but if I get the 30 HP gain they are saying that would show on my time slips for sure(12% increase in HP) We shall see.
 

·
Registered
Joined
·
864 Posts
are you going to install b4 the spring???
 

·
Registered
Joined
·
516 Posts
Discussion Starter #9
are you going to install b4 the spring???

I probably am but I dont know if I will get the best results doing it while its already cold. I will probably do it within the next week or two. The only thing is I cant test squat is traction is an issue so we shall see.
 

·
Registered
Joined
·
1,793 Posts
A bad tune will destroy an engine..... for $69.... I would be leary..... a bad tune can destroy an engine quicker than some can say rumpilstilskin.....
 

·
Registered
Joined
·
1,793 Posts
and if you do have a warranty left..... then it will be gone now......
 

·
Registered
Joined
·
456 Posts
and if you do have a warranty left..... then it will be gone now......
Technically, so does your first 1/4 mile run. He'll be good so long as he uninstalls it before he dragging the carcass back to the dealer.

-Dennis-
 

·
Registered
Joined
·
516 Posts
Discussion Starter #13
Technically, so does your first 1/4 mile run. He'll be good so long as he uninstalls it before he dragging the carcass back to the dealer.

-Dennis-
Interesting.. Never knew that. Wouldnt change the way I drive. Have you ever known anyone who had a warranty voided because he dragged his car? Is this just from data collected from our computers? If thats the case than no one should have one on our cars.
 

·
Registered
Joined
·
456 Posts
Not personally no. But if you blow your motor at the drag strip I wouldn't mention it to the service manager ;)

-Dennis-
 

·
Registered
Joined
·
1,793 Posts
Technically, so does your first 1/4 mile run. He'll be good so long as he uninstalls it before he dragging the carcass back to the dealer.

-Dennis-
Yea I dont think its against warranty to go to the drag strip. all you are doing is accelerating fast .... and there is no spped limit that voids your warranty... that I aware of though....

also, not sure how good this programmer is but it sounds to cheap to be undetectable by the dealer... dealer will most likely see the change in tune (even if he changes it back) and then void his engine warranty.. and trans warranty..... just throwing out a caution for his consideration.....
 

·
There was one?
Joined
·
2,308 Posts

·
Registered
Joined
·
516 Posts
Discussion Starter #17
OP,
Have you searched an found this thread yet? A good read.....

http://www.g8board.com/forums/showthread.php?t=36978&highlight=force+chip
Thanks for the link. I didnt come across this on a search so I must have missed something there. I read similar type things when I did a google search. 90% worthless and apparently does something for WRX's. Dont know why it would work for them and noone else.

I am still waiting on the device or whatever you want to call it to arrive.

My car is running great right now due to the cold temps. Its snowy season now (Although not very snowy) so we shall when I can get this thing installed and tested out. I have new rears that grib great inthe snow but cut loose pretty easily on dry salted roads so testing may not work well unless we get some rain soon.
 

·
Registered
Joined
·
516 Posts
Discussion Starter #18
Well I just got the Chip or whatever you want to call it this weekend. Its been too cold and snowy to install so I will have to wait for a better day.

I unscrewed the case to see what was inside and it didnt look like I had anticipated. I had seen some of the IAT type things with just a tootsie roll resister inside a plastic box but this was different from the appearance anyway. It may be a resister still but there was a circuit board with what appeared to be a chip installed in the center of the board.

I wasnt able nor did I want to pull it out however I was just able to able to peek inside the case. I saw something similar to the pic below installed on the circuit board.

 

·
Registered
Joined
·
1,793 Posts
Dont do it man..... throw it out...... just not worth it....
 

·
Registered
Joined
·
516 Posts
Discussion Starter #20
Well I installed it a few days ago. The installation was very easy. It required almost nothing and took all of 10 minutes. It does not require any splicing of wires and you can take the chip on and off in 2 seconds. It has these 2 clips that more or less slide over your IAT wires and then the chip wires clip in. So from that stand point its very nice. Since its Cleveland and its winter I cannot test it for performance as the roads are always either salty or wet. But from a milage stand point the chip has lived up to the claims thus far. I am getting a combined 21-22 MPG even with starting it and letting it warm up longer with a 60/40 split (Highway / City). I reset the mpg estimator and got 30.1 MPG during my commute this morning. I have gotten that or better the past couple days on the highway. The idle seems plenty smooth and might be slightly smoother with a little less ticking but that might just be coincidence.

I am not going to comment much on the performance end of it yet. The road conditions just haven't been available for testing. The only thing I can comment on is the dead spot in the power band around 45-5500 is more apparent (in first). It feels like a rubber band. The power seems a little stronger before and it seems to sling shot out of the dead spot with more power than before (The dead spot seems shorter). The power seems to go right into 2nd and the shift into 2nd seems to be quicker and more crisp which is HUGE if it does this on a consistent basis. If I get dry road I'll try to get some runs in to compare with the fall. If I am not pulling sub 7 0-60's on a regular basis this chip is only good for mileage. With the addition of my Axle backs I went from an average of 7.2 seconds down to 7.0-7.1. We Shall See.
 

Attachments

1 - 20 of 64 Posts
Top