Pontiac G8 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I've been trying to troubleshoot an issue with my car for over a year. It started with an intermittent sputter after start up that eventually led to an every morning sputter then to a timing chain grind every time the car sits a few hours. Intermittently, it throws a p0300 accompanied by p0301, p0303, p0305.

I've replaced the MAF sensor, spark plugs, coil packs, injectors, purge valve solenoid, intake gaskets, throttle body position sensor, camshaft sensors, and timing chain. I've also had a dealership reflash it and test the fuel pressure. Fuel pressure was good and they suggested bad fuel as the problem. I put injector cleaner in again, and use top tier fuel now, but the issue persists.

After scouring the internet some more, I came across battery and alternator issues causing misfires. I tested them last night at autozone and the diodes in my alternator tested faulty and it was surging between 14.5-14.8 bolts. The alternator is roughly 3 years old. Could it really be the cause of my starter/timing issues?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Update: I pulled the serpentine belt last night and hooked the battery up to a charger. After 3.5 hours of sitting I swapped the charger to a quick start set up and cranked the car on. No issues, it started right up.

I set the battery back to charge and left it to charge. After 10 hours or so I repeated the process and it fired right up, then a quick grind but no obvious sputter. It seems like my alternator and battery are making things worse, but aren't my underlying issue.
 
1 - 2 of 2 Posts
Top