Pontiac G8 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So my 2009 G8 is having major issues. outta the blue the car started running like crap and the screen flashed safety mode then reduced power. just sits there a starves for air or fuel or something but runs like ****. I read it was the throttle body so i replaced the whole throttle body ($177.00 at oreillys after tax) and installed it, but it still does. i know it has to relearn and can run ruff till it does but ive ran it quite awhile and nothing. does anyone have any other ideas?? did have access to my code reader to know what codes its shown. do know i had to change my bank 1 ho2 sensor but doubt thats cuz the problem, or could it? thanks for any help and/or ideas
 

·
Premium Member
Joined
·
8,864 Posts
...I read it was the throttle body so i replaced the whole throttle body ($177.00 at oreillys after tax) and installed it, but it still does. i know it has to relearn and can run ruff till it does but ive ran it quite awhile and nothing. does anyone have any other ideas??...
Is the replacement throttle body's blade the same color as the one on the original throttle body? For $177 after tax am presuming the replacement is the TechSmart gold blade throttle body.
...did have access to my code reader to know what codes its shown...
What codes are displayed? Was anything plugged into the on-board diagnostic port prior to the major issues?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Is the replacement throttle body's blade the same color as the one on the original throttle body? For $177 after tax am presuming the replacement is the TechSmart gold blade throttle body.
What codes are displayed? Was anything plugged into the on-board diagnostic port prior to the major issues?
there was one, cant recall it off hand but it was saying bank one was to lean. i wont be able to get a new exact code til friday when i get back over to where its sitten, but ill list them when i get them on friday. but thanks for your reply. as far as the throttle body again cant recall brand, it was what ever they had in stock.
 

·
Premium Member
Joined
·
8,864 Posts
A lean condition could be caused by a vacumn or exhaust leak, fuel starvation or a faulty oxygen sensor(s). None of which would trigger reduced power, safety mode. More specific diagnostic codes may help to pinpoint the issue.
 

·
Premium Member
Joined
·
4,687 Posts
If the car went into the safety mode / reduced power condition, it pretty much is pointing to the throttle body. When the throttle body develops a problem IT would also tell the check engine light to illuminate. If that MIL light illuminates, there must be 1 or more fault codes logged in at that time. Think you need to get that info, to enable yourself to move forward. The V6 requires an idle learn procedure to be performed, to have any chance of getting that TB up to its 100 % operating condition.
Based on the cost along with its lifetime warranty is nice, but that doesn't mean that just any after market unit will work as it should.in the G8.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
so i replaced both throttle poision sensors (pedal & throttle body) still wont go over 1800 rpm. still reduced power and safety mode lights on. the codes are p2111 and p1222. both i assumed referred to throttle position, which i replaced. ive tried everything ive found online to get car to relearn with new parts, but keeps idles real ruff. smooths out when in gear and will roll but still wont idle up over 1800 rpm. ready to just tow it to dealer and have them reprogram it, and pray thats fixed, lol. thanks for any advise
 

·
Premium Member
Joined
·
8,864 Posts
Presuming they're both new, what brand(s) are the replacement parts? Is the butterfly valve the same color on the replacement and old throttle body? The new throttle body is plug-n-play and must be relearned via a Tech II or other device.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
ok thanks everyone for tips. heres my update. so with no other choice i had vechile towed to local dealer. thats was my first mistake, lol. took 3 days and the manager called me to explain. saying there where to many error codes and it wouldnt let him reprogram it. but did get alist of codes. p0122 tp or app sensor 1, po222 tp or app sensor 2, p0100 maf circuit, p100 maf range, p0480 coolant fan, p0481 fan control relay, p0706 trans control system fault, b3031 security system in learn mode, and finaly b3060 transponder not programed. so with all of these theses nothing they can do, and here i thought the dealer could fix it. But now to me, and mind you im no mech, but the first two codes are the two throttle position sensors i replaced. the 3rd and 4th are for mass airflow, which popped on cuz car runs like **** cuz of 1&2. cuz they werent on earilier. now the b codes the mech said is probaly from when i had to replace my lost keys and programmed them with key coder tool. he said if i did the 10 min key on thing to reprogram keys it should get rid of them codes, ofcourse he also said ild have to do it to two keys. my second key is packed away in storage rite now and didnt wanta pay 200.00 for a new key. i wonder if i replaced the BRAIN WITH A REMANUFACTORED ONE CODED TO MY VIN, IF THEN ITLD LET THEM REPROGRAM FOR NEW SENSORS. dealer basicaly said to give up on her, but as good as it was running before the throttle sensors went out, i cant just let it go, lol. so i guess ill erase the codes on it as of now and try to reprogram it myself with the xtool. doubt itll work but ill update when i do. thanks again everyone
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top