Pontiac G8 Forum banner

1 - 20 of 44 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So I stored the wifes G8 before Corona. I know nothing about G8's more of a diesel guy. Anyways, just before storage she had some exhaust work done and they cut out the catalytic and straight piped it. Sounded cool and ran fine. The last day before storage I filled it with high 91 octane and stabilizer, parked it in a non heated garage and disconnected the battery leaving it on a tender. Come about a week ago I pulled it out. Connected battery and fired it up. It immediately started to lope at idle. Ran like a bag until I applied throttle. I idled it around the parking lot and it stopped lopeing. Took it for a very gentle drive and the engine light began to flash and it started shaking like a plug had fouled. Shut it off and started it and the problem repeated. Currently it will start and idle but not happily. It currently is throwing 2 codes, P2273 and P013E . I'm sure this is an O2 issue but curious if I can fix it without installing an entire exhaust system. I know nothing about these cars yet. Help!
 

·
OGOC Member
Joined
·
2,619 Posts
First question is the engine light flashing or is it on steady?
 

·
Registered
2009 G8 GT
Joined
·
123 Posts
Both of those codes are for the rearward O2 sensors, if you no longer have those do to your new exhaust set up probably need someone to tune those out.
 

·
Registered
Joined
·
17 Posts
First question is the engine light flashing or is it on steady?
Engine light was on steady before I took it for the most recent drive. On the latest drive the light went from on steady, to flashing and beeping as soon as I went over 60k. As well the whole car started shaking and a loud vibration noise until I slowed down to under 50k, then was able to slowly drive it back home again... haven't driven it since.
 

·
OGOC Member
Joined
·
2,619 Posts
Ya you need to have the rear O2 sensors tuned out. That's the problem because you have no cats.
 

·
OGOC Member
Joined
·
2,619 Posts
You will have to go to a shop that has the software. Mine was done with HP tuners. I have a custom tune. And yes that's why it runs like crap. The sensors are reading to much fuel and trying to lean it out. But it causes confusion in the computer so it goes in to safe mode,so you don't blow it up.
 

·
Registered
Joined
·
17 Posts
You will have to go to a shop that has the software. Mine was done with HP tuners. I have a custom tune. And yes that's why it runs like crap. The sensors are reading to much fuel and trying to lean it out. But it causes confusion in the computer so it goes in to safe mode,so you don't blow it up.
Do you think that is something they could come to me to do ? I dont feel I should drive the car down the hwy for an hour to a shop... what do you think? I would trailer it if I have to as well...
 

·
OGOC Member
Joined
·
2,619 Posts
I wouldn't drive it. And yes they can come to you if your stuck. Just a laptop is plugged into the car and they use the software to turn them off. Then it should run new again.
 

·
Registered
Joined
·
17 Posts
I wouldn't drive it. And yes they can come to you if your stuck. Just a laptop is plugged into the car and they use the software to turn them off. Then it should run new again.

Thank you so much !! I guess my last question for you is, is there someone you would reccomend to tune my car? I live an hour north of Barrie, ON.
 

·
OGOC Member
Joined
·
2,619 Posts
Oh God up there I'm not sure who's there. Maybe hit a car show there if there is any and ask or maybe just google. Tuner in Barrie. Or what ever town your in.
Always happy to help
 

·
OGOC Member
Joined
·
2,619 Posts
I'm all the way out in Oshawa
 

·
Registered
Joined
·
17 Posts
Oh God up there I'm not sure who's there. Maybe hit a car show there if there is any and ask or maybe just google. Tuner in Barrie. Or what ever town your in.
Always happy to help
Well again thank you so much !! you have shed some much needed light on my situation !! I will probably have to google what's in my area but at least I know what to say now !! Have a great day !! 😎
 

·
OGOC Member
Joined
·
2,619 Posts
Your welcome anytime. Let us know how you make out with it.
 

·
Registered
Joined
·
6 Posts
So I stored the wifes G8 before Corona. I know nothing about G8's more of a diesel guy. Anyways, just before storage she had some exhaust work done and they cut out the catalytic and straight piped it. Sounded cool and ran fine. The last day before storage I filled it with high 91 octane and stabilizer, parked it in a non heated garage and disconnected the battery leaving it on a tender. Come about a week ago I pulled it out. Connected battery and fired it up. It immediately started to lope at idle. Ran like a bag until I applied throttle. I idled it around the parking lot and it stopped lopeing. Took it for a very gentle drive and the engine light began to flash and it started shaking like a plug had fouled. Shut it off and started it and the problem repeated. Currently it will start and idle but not happily. It currently is throwing 2 codes, P2273 and P013E . I'm sure this is an O2 issue but curious if I can fix it without installing an entire exhaust system. I know nothing about these cars yet. Help!
 

·
Premium Member
Joined
·
5,220 Posts
Either replace both catalytic converters or have then tuned out so the engine control module doesn't report them. Reason(s) for removing the catalytic converters? Did the shop not mention subsequent issues prior to doing the work?
 

·
Registered
Joined
·
17 Posts
Either replace both catalytic converters or have then tuned out so the engine control module doesn't report them. Reason(s) for removing the catalytic converters? Did the shop not mention subsequent issues prior to doing the work?
No the guy at the shop said he couldn't order me the replacement parts so my only option was to straight pipe it and he never said a word about any issues I would have after....
 
1 - 20 of 44 Posts
Top