Pontiac G8 Forum banner
1 - 20 of 68 Posts

Registered
Joined
70 Posts
Discussion Starter · #1 · (Edited)
Hey everyone, I am new to the Pontiac world and I am loving it so far. However I encountered this problem when I got my Mid-Muffler and Resonator Delete along with my previous muffler delete. My two Oxygen sensors went off and my car suddenly lost all power. The RPMs were going up however the speedometer wasn't. The errors that popped up were the 2 Front Oxygen Sensors. If anyone knows what I can do please help me out. 馃槃

The car does not have a Cold Air Intake nor does it have a tune (yet).
 

Registered
2009 G8 GT
Joined
584 Posts
Your O2 sensors would be before the mid muffler resonators and the rear mufflers, did you do something with the Catalytic converters?
 

Premium Member
Joined
9,480 Posts
Welcome. At this juncture, would return to stock and leave it be. The two front (upstream) oxygen sensors do not monitor the catalytic converters as they're pre-catalytic converter. The ecm/pcm compares the values of the front (upstream) and rear (downstream) oxygen sensors to determine the efficiency of the catalytic converter.
 

Registered
Joined
224 Posts
I did the Solo with J Pipes sound cancellation with no mufflers or resonator on my V6 and I haven't had any problems.

Did you run the car with no pipes after the cats?

The O2's would pick up the extra oxygen and you would throw codes.

If this is what happened clear your codes and as long as the cats are functional and your 02's are good and you are running a good length of pipe past the cats your problem should be resolved.
 

Registered
Joined
5,138 Posts
If the OP still has the stock cats on. You will never get a 鈥淕ood鈥 sound from the exhaust. Stock cats are the biggest choke point of the whole system.
 

Registered
Joined
70 Posts
Discussion Starter · #9 ·
I did the Solo with J Pipes sound cancellation with no mufflers or resonator on my V6 and I haven't had any problems.

Did you run the car with no pipes after the cats?

The O2's would pick up the extra oxygen and you would throw codes.

If this is what happened clear your codes and as long as the cats are functional and your 02's are good and you are running a good length of pipe past the cats your problem should be resolved.
This is basically what they put, I did change it back to stock. The left side on the picture is the front of the car and the right is the rear. They didn't touch the Cats from what I know.
Automotive tire Tire Automotive exterior Wood Tread
 

Registered
Joined
70 Posts
Discussion Starter · #10 ·
Welcome. At this juncture, would return to stock and leave it be. The two front (upstream) oxygen sensors do not monitor the catalytic converters as they're pre-catalytic converter. The ecm/pcm compares the values of the front (upstream) and rear (downstream) oxygen sensors to determine the efficiency of the catalytic converter.
It works fine now, however I do not want to keep it stock since I have it labeled as a project car. (I changed the parts back to stock)
 

Registered
Joined
70 Posts
Discussion Starter · #13 ·
Another thing I forgot to inform you gentlemen about is that I do not have a Cold Air Intake, nor did I get the car tuned. If the Cold Air Intake is the issue please let me know as soon as possible. Thank you for all the help my friends.
 

Registered
Joined
224 Posts
Another thing I forgot to inform you gentlemen about is that I do not have a Cold Air Intake, nor did I get the car tuned. If the Cold Air Intake is the issue please let me know as soon as possible. Thank you for all the help my friends.
A cold air may get you a few HP's but you don't need a tune for a CB ext or CAI but it can help optimize all your power.
 
1 - 20 of 68 Posts
Top