Pontiac G8 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5,210 Posts
Discussion Starter #1


So got my first mod. For my baby . Went with the orssom . I know its gonna sound crazy but haven't taken it on the highway to open it up and see if I notice a difference in any way . I wasn't sure but figured I'd drive the car in normal conditions while it spends its time relearning the air flow values. They say 500 km and the check engine light should turn off. If not ,I guess I'll be up for a tune. Which was gonna happen eventually anyway.
On a down note , I found out from my mechanic when we did my oil that I may have a rear main seal leak. Which from a search on the forum saw that its covered under warranty. I hope that's all it is . Any thoughts on this would be nice . I think he said it could also be the oil pan but dont quote me on that . Well safe driving people.

http://i1307.photobucket.com/albums/s583/funkygreens/IMAG0063_zps58e52dc7.jpg
 

·
Registered
Joined
·
5,210 Posts
Discussion Starter #2
Click on lower link . Why when I tried to upload the photo instead of the link , a link popped up instead of the image . I clicked on the mountain icon and pasted to the http address box ? Doing this for first time via cell phone ,so my bad. Well there's the link anyway.
 

·
Registered
Joined
·
5,682 Posts
Just be careful with an intake that opens upward like it does cause if any water comes thru those scoops you're gonna have a bad day.
 

·
Registered
Joined
·
5,210 Posts
Discussion Starter #5
[ Just be careful with an intake that opens upward like it does cause if any water comes thru those scoops you're gonna have a bad day. QUOTE]
I did do the marine water sealant on the scoops. I'm hoping I used enough.
One thing I don't understand is that I have to worry about the scoops and water but not the front where the hood and bumper meet and come through now that there's no weather strip there for air to get through ?

Thanks unexpected.
 

·
Registered
Joined
·
5,210 Posts
Discussion Starter #6
Hey jackalope , just tried my remote starter and it doesn't want to kick on . Is this do to the check engine light issue during its relearning process? Or do I have another issue now ?
 

·
Yep, that just happened..
Joined
·
5,024 Posts
If any engine light is on, remote start won't work. Clear the code (if you can), and the remote start should work fine...
 

·
Registered
Joined
·
5,210 Posts
Discussion Starter #8
Thanks for the info . Started to worry I had another issue .
 

·
Yep, that just happened..
Joined
·
5,024 Posts
You're welcome. No problem.
 

·
Registered
Joined
·
596 Posts
You can make a weather stripping i am sure from something from home depot. Or you could find one on ebay or something.
 

·
Registered
Joined
·
5,210 Posts
Discussion Starter #11
The weather stripping was either to be cut 500 mm or just remove ,according to orssom. This is to let air flow into the CIA . No leaning the radiator back .

Oh and she learned the new air values tonight ,so no more check engine light and no tune . Not until the 100,000 warranty is up ,then I'll start beating on that door. Haven't opened her up yet but I wanna say I notice a difference just from take offs and some moderate acceleration with the gas peddle . So far so happy . Oh and gotta thank Dan linnett for the help as well as the guys at orssom. Oh and anyone else that made me feel better about going this route.
 

·
Premium Member
Joined
·
10,244 Posts
good job on your mod cherry, OP.

We gotta get you posting from a real computer, not your cell phone, where it tends to be better at quoting and embedding pictures. Maybe someday, ha ha ha.

You already got my PM, I recommend Cappellinos for the warrantee work if you don't have a place already picked out. And don't you have access to a code scanner, with working at a dealership and all that? Thought it would be trivial for someone manually clear the code from the device?

Do you daily drive your car through snow and ice and salt like I do? Keep an eye on that filter, first sign of anything coming down or getting scooped in past the filter to the MAF and there could be problems. On the other hand, if you monitor it and it's always clean, then sounds like a plan!

--zep
 

·
Super Moderator
Joined
·
4,911 Posts
The orssom is a good lookin piece.
 

·
Registered
Joined
·
5,210 Posts
Discussion Starter #15
Thanks everyone. Appreciate the compliments.
Hey Zep. Will get at you on the pm later. I'm at work til nine or so .
 

·
Registered
Joined
·
5,210 Posts
Discussion Starter #16 (Edited)
Hey Zep. Decided to just send a normal reply instead of the pm,figured it wasn't necessary. I got the check engine light off again and hope it stays off now. Dan Linett said it was normal for that to happen.
As for cappellinos ,if my place gives me crap ,ill go there . Shop foreman here said there shouldn't be an issue with me having an aftermarket intake and my warranty. He said its most likely the oil pan and I have to wait til the 20th to get her in and looked at. I saw your warning on making sure the shop also does the plastic parts on the tranny and to make sure they don't reuse them if they do the rear main seal . Sorry for the slight vagueness. I read it last night .
As for the computer thing , maybe one day lol. I finally got photo bucket , baby steps ,baby steps lol.
I'll get at you when its time for the tune and what to do. Thanks for the help. Well back to work.
the plastic ball socket that connects the shift linkage on the tranny to the shifter.that was the part I was referring to Zep .
We have a black 08 in our shop today. In fact still there when I left tonight. Rarely see a g8 in our shop. Kinda thought there was a reason for it and that's why I asked about who is best to go to . Ttyl . Goin to bed .
 
1 - 16 of 16 Posts
Top