Pontiac G8 Forum banner
1 - 20 of 51 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 · (Edited)
So started my cam swap weds 4/17 and finished sat 4/20, Did all the work by my self had a buddy that was supposed to help but he got stuck working 16's thurs , fri and sat. Worked about 2 hours on weds and got the, roto-fab off, radiator, intake, and made sure all the maniflods bolts would break free, And they all did with ease.
Thursday worked from 630 to 930 and managed to get everything apart and prepped for re-assembly.
Friday worked from 630 to 9 and got the valve springs and seals installed on heads. Installed the headers, placed heads on block and realized i had the wrong head bolts. I had 04 and older ls1 block head studs, which are too long. So made a few phone calls and was stuck till the morning.
Saturday got started at 1130 after i got back from swapping the studs for the right bolts.
Got the heads torqued and headers bolted up and decided to cut 1 in off the pacesetter headers, where they hook to the connection pipes, and welded the connection pipes to the headers and got them all bolted up. This was probably the most time consuming part. Finished installing pushrods, rockers, intake and hooked up the pcv stuff.
Then moved on to radiator, first trans line i go to hook up and push the spring clip in place it goes flying somewhere, looked for the SOB for like 15 mins, then ran to orielys hoping they had one and they did. Got back and buttoned everything up.
I think it was running before 4pm.
Only issue i had after that was header hitting the steering shaft so removed driver front wheel, and welded a 1/2 socket to a long punch heated the header red hot and gave her some love taps, Problem solved.

Also took the computer/PCM out so i could have livernois flash a cam tune to it and let me tell you that was one task in it self.

Took a bunch of pictures only gonna upload the main ones, Enjoy.

First the car



The puzzle pieces




Livernois 1C Cam Livernois Motorsports Dual Valve Spring Package (Livernois Motorsports Dual Valve Springs, Titanium Retainers, Valve Spring Locators, Locks, & Valve Seals)
ARP Head Bolts
MLS Head Gaskets
Hardened Pushrods
GMPP LS7 Lifters (16)
GMPP LS2 Lifter guide (4)
GMPP LS2 Valley Cover
GMPP Valve Cover Breather Block-Off
GMPP LS7 Camshaft Sprocket
GMPP Timing Chain Dampner
GMPP PCV Hose
GMPP LS2 Lifter guide kit
GMPP Exhaust Gaskets
ARP Timing Chain Bolts
2 Water pump gaskets
Timing cover gasket
Crankshaft shaft seal
Pacesetter headers













 

·
Registered
Joined
·
87 Posts
Discussion Starter · #2 ·
Now the fun part, I loosed all the oil pan bolts and only moved it down maybe 1/2 in and used a wrench to get the pick up tube bolt loose, then wrapped it with safety wire and twisted it enough to use the wire as a wrench and and a safety measure to not drop bolt and it worked perfect.



















 

·
Registered
Joined
·
87 Posts
Discussion Starter · #3 · (Edited)












First start and idle
http://youtu.be/7qKE_7N_Slc




Correction..She made 404/395

Ill have the graph tomorrow my fiance picked the car up friday and they forgot to give it to here, im gonna see if my buddy can just email it in the morning.

For a 1c cam im pretty impressed, even the livernois crew said they were some awesome numbers for that cam. Made a run at 408 but it was on the lean side he said.

Any questions feel free to ask, I also have a bunch of other pics.

Thanks

Jesse

 

·
Registered
Joined
·
524 Posts
Nice writeup. Sounds good. Wish I knew how to take apart and put together a motor to do this myslef. Did you cut 1" off from the headers or mid section?
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #5 ·
Off the headers I was gonna do the mid section, but this was much easier. Only did it cause I didn't like how far they were gonna push the catback back.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
895 Posts
Are those wheels VB3's
 

·
Registered
Joined
·
895 Posts
Looks really good, not many G8s run them, i like those the best
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #9 ·
Yea I get so many compliments on them, the picture doesn't really do justice. I wish it was a little lower but I enjoy having a somewhat decent ride on these smooth Michigan roads.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
116 Posts
Almost finished with my DoD delete and had the same problem with my Kooks LT headers and connectors (no cats) to the Corsa catback system that was already on the car when I bought it. The driver side was fine but the passenger side is about 3/4" to 1" too long. I did what I could to make it line up but it's just too long. Gonna take the connector to a local muffler shop and have them cut a section out and re-weld. Other than that no problems at all.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #11 ·
I never heard of this issue with the kooks, I knew I was gonna have the problem with the pacesetters as just about everyone does, but most just let them push the exhaust back.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
116 Posts
I decided I'll drop the exhaust and loosen up the connections all the way back and see if I can get enough room for the connector pipes to fit before I do any cutting. Last night woke up thinking I forgot to torque the lifter tray bolts on the passenger side. Damn! Kept thinking about it and decided to pull the head and look, otherwise I knew it would drive me crazy every time I start the motor. So today I pull the intake and head and find the bolts nice and tight. $45 for a new head gasket and a couple hours work and at least I'll be able to sleep tonight! Can't wait to start er up.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #13 ·
Yea nothing's better than piece of mind, I made my self a check list of the important stuff with all the torque specs and crossed them off as I went. Sounds silly to some but in my line of work 70% of my torque's my name is signed off on them.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #15 ·
Question to those with cams/custom tunes, when coming to a stop how noticeable is your down shifts. I feel sometimes it jumps pretty hard around 7 mph. Sometimes I barely notice it other times it jerks pretty hard.
Before I just had a livernois 93 tune flashed for my Roto fab and I don't believe I ever felt it down shift. I made sure Andy was aware of this before they dyno tuned it. They said they messed with it slightly but that it was just the nature of the car down shifting.
Also this first started on my start up tune which was from another cars dyno tune for a stage one cam, he said he never touched the trans file so nothing should have changed.

Any input would be appreciated.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
63 Posts
I'm on a Livernois tune for my mods, and I sometimes get a little bit of a noticable shift to 1st as I'm coming to a stop. It isn't terrible, as I'm sure my wife would let me know if it was, but it's sometimes there. It's usually when I'm coming to a stop very shortly after driving in a more spirited fashion.
 

·
Registered
Joined
·
116 Posts
Got everything together. I want to retract what I said about the Kooks system not fitting. I swapped the two connector pipes and everything fit fine. I thought they were identical but obviously they are a little bit different. In fact, I found on my garage floor the tags that were attached to them and they do identify left and right. My goof. So far everything runs great. Very loud. My system is the long tube Kooks with connectors to the Corsa catback system. No cats. It is loud when I get on the gas. I may rethink this and get the kooks cats just to mellow things out a little. Or maybe the noise will grow on me. Now to find a nice wide open road to do some driving. Maybe a trip up to Monterrey on Highway 1.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #18 ·
that's good you got it all together, my exhaust is honestly perfect best I've heard so far. I leave around 540 am it rumbles the house a little but it's not crazy, I have no cats into magnaflow x-pipe muffler into stock resonators to borla bullets. Very quiet at cruise speed with no drone at all. The magnaflow x actually made mine quieter considering I removed the mid pipe and pup cats.

Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
1,097 Posts
Question to those with cams/custom tunes, when coming to a stop how noticeable is your down shifts. I feel sometimes it jumps pretty hard around 7 mph. Sometimes I barely notice it other times it jerks pretty hard.
Before I just had a livernois 93 tune flashed for my Roto fab and I don't believe I ever felt it down shift. I made sure Andy was aware of this before they dyno tuned it. They said they messed with it slightly but that it was just the nature of the car down shifting.
Also this first started on my start up tune which was from another cars dyno tune for a stage one cam, he said he never touched the trans file so nothing should have changed.

Any input would be appreciated.

Sent from AutoGuide.com Free App
Not much help here but.... I am having a similar problem. My car is harshly banging into 1st after stopping. I tried reverting to the stock Tcm tune but it still doesn't. I'm hoping the dealer can figure it out. Mine feels like I'm getting rear ended after I come to a stop. It usually occurs after spirited driving as well.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #20 ·
Yea I talked to a local member and his car does about the same, he said he is just used to it now.. now I'm not sure if it feels like getting rear ended everytime I stop, but basically like your in manual mode and downshift to first around 7mph.

I drove in my buddy's bone stock g8 this weekend and his car you feel nothing at all. Compared to mine his feels like a manual car holding the clutch in coming to a stop lol best way I can put it.
It's something in the engine tune, has nothing to do with the trans. As my start up tune was engine only and it did it.

I thought I would get used to it but it still bugs me, I've been using manual mode in traffic as it only goes to second, but say I tap down to first it feels like the engine is loaded, almost like going from neutral to D from a stop. Just get a slight jump forward.

Any tuners know what causes this or is it just normal with a cam?

Thanks

Jesse

Sent from AutoGuide.com Free App
 
1 - 20 of 51 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top