Pontiac G8 Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
562 Posts
Discussion Starter · #1 ·
Ok I just got my 404 stroker in the car I have about 2k miles on tge new motor. I have a 160 stat but im hitting 210 temps. When I had the motor out I didnt clean the radiator. But did drain it. I was thinking because I live in texas and summer is right around the corner. Can I flush the system and just do distilled water and an additive like wetter or purple ice?

Also is there a different fan setup we can do?

Sent from AutoGuide.com App
 

·
Registered
Joined
·
596 Posts
maybe you have an air pocket?
Are your fans working?
 

·
Premium Member
Joined
·
562 Posts
Discussion Starter · #3 ·
maybe you have an air pocket?
Are your fans working?
Fans are working fine.
And air pocket idk. When the car was running I opened the steampipe open till coolant came out.

Sent from AutoGuide.com App
 

·
Registered
Joined
·
775 Posts
Take te cap off when the car is cold. Let the car idle till it gets to temp, or thermostat opens, watch the fluid cycle through. It may be low on fluid.
If it doesn't cycle, thermostat may be stuck.

Also, when it was tuned, were the fans adjusted in the tune?
 

·
Premium Member
Joined
·
562 Posts
Discussion Starter · #7 ·
Idk what they are set at. Im running 210 in hwy driving. Im going to flush the system tonight and see if my 160 stat is working right.

Sent from AutoGuide.com App
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top