Pontiac G8 Forum banner
41 - 60 of 65 Posts

· Premium Member
Joined
·
10,685 Posts
Indeed the carbon fiber themed steering wheel looks fantastic and is a great interior addition to the G8.
 

· Registered
Joined
·
174 Posts
Discussion Starter · #43 ·
Thanks guys.

Finally got the tune figured out, I had the car running but it just didn’t want to idle and was running lean. Found a good sized leak in the intake manifold with the smoke machine. After replacing the manifold, all is well.

Rear cradle has been sandblasted and painted, just waiting on some suspension pieces so that I can button it up.
 

· Registered
Joined
·
107 Posts
Fellow West Chester G8 owner here. Have you had it out on 202 at all in the past few months? I saw a blue G8 a little while back. Awesome job on the LS swap! I'm running the corsa cat-backs as well and i absolutely love the sound. It's loud when you want and quiet when you don't.
 

· Registered
Joined
·
174 Posts
Discussion Starter · #45 ·
Fellow West Chester G8 owner here. Have you had it out on 202 at all in the past few months? I saw a blue G8 a little while back. Awesome job on the LS swap! I'm running the corsa cat-backs as well and i absolutely love the sound. It's loud when you want and quiet when you don't.


Thanks

I’ve had it out on 202, but that’s quite a while back. I haven’t driven it yet this year. It’s been sitting on the lift since the beginning of March. lol
 

· Registered
Joined
·
174 Posts
Discussion Starter · #47 ·
BAS, I did not mean to offend in other thread. Apologies if it came across that way.

Thank you. Hoping to have it on the road in the next few days.

V8 swap was not hard. If one can source the engine bay wiring harness and engine wiring harness, everything is plug and play.
 

· Registered
Joined
·
174 Posts
Discussion Starter · #50 · (Edited)
Out with the old,



In with the new


SS Upper Control Arms, ZL1 Trailing Arms & Toe Rods, Camaro 3.45





Got the car buttoned up this past weekend. Evidently my trans builder f*ed something up, not a single code in ecm or Tcm. Car drifts forward in drive about a foot and then comes to a halt. Perfectly fine in reverse. If I command third gear with scan tool, also fine.

Guess this is what happens when you pay someone to do a job and don’t do it yourself. Trans is coming back out, I will tear it into it myself and figure it out.

Gxp trans cooler and zl1 converter on the way to cheer me up.
 

· Registered
Joined
·
174 Posts
Discussion Starter · #52 ·
Jeez....that new rear cradle is a thing of beauty....
Sucks your trans is giving you problems....one step forwards, two back....

Thanks! Its not new ;)


Sandblasted, Etch primed, and painted. I did the same with the front cradle.




Trans problem sucks, that will definitely be the last time I pay someone to rebuild one for me.
 

· Registered
Joined
·
174 Posts
Discussion Starter · #53 ·
Update.



Yanked the trans today and installed another one I bought earlier this week with the zl1 converter. Waiting on filter to show up tomorrow and need to go get new fluid, but it’s in the car!



Old one is on the bench in pieces.



Found that the snap ring for 1-2-3-4 was not installed correctly



3-5-R clutches and steels took most of the heat/wear/damage.



Drum took some heat too




Will finish up the install tomorrow and take it for a ride! Finally!
 

· Premium Member
Joined
·
10,685 Posts

· Registered
Joined
·
63 Posts
Excellent color choice. Interesting seeing what you did for the swap. I'm always eyeing LS3 dropouts on Ebay and daydreaming. I'm really happy with the car as it is though. The color is what got me...That and the fact I was driving 30,000 miles plus a year.
 

· Registered
Joined
·
174 Posts
Discussion Starter · #57 ·
Thanks!

Buttoned it up this morning, had a few tuning issues with new transmission as it was out of an 09 and the donor stuff was from an 08 running older software. Had to flash a stock 08 file into the 09 Tcm, then flash the tune in, then change the vin. All is well.

Drove it home and man did it feel great. Still needs a wheel alignment, but this far it runs like a champ. Very smooth. Guess I did alright putting the bottom end together.

There’s an o2 sensor code that keeps popping up, has to be a bad wire, other than that everything is good.
 
41 - 60 of 65 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top