Pontiac G8 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Don't know if this is the right forum for this or not. I read the couple existing posts on this topic like this one, but wanted to get some fresh feedback.

I have a 2008 GT. Only mods (for the moment) are Solo axlebacks and a Superchips Flashpaq 87 Octane tune.

So I go out this morning to drop my kid off at school. Start it up, system check complete as we buckle in. Put it in drive and *clunk* as it jerks into gear. I get the dreaded Red X and ESC OFF messages on the DIC. Kid's school is close, 25mph the whole way, but I notice it's definitely in 2nd gear the whole way, doesn't shift at all.

Come home, went into reverse okay. Parked, grabbed the Superchips and read the codes. P0700 "Tran Ctrl Sys Error" and P1825 "Internal Mode SwitchInvalid Range" are thrown. I take it back to stock, and it starts and shifts fine.

This is the third time this has happened. Taking it back to stock then re-flashing it to the 87 Octane tune seems to fix it. From reading the threads here, it sounds like it could be a solenoid or the battery. (Was 57°F here this morning, engineering mode says the battery is reading 14.7 volts.) But flashing back to stock has always seemed to fix the problem.

Any other info on this?
 

·
Registered
Joined
·
546 Posts
Your're most likely going to have to replace the trans shaft switch,it mounts inside the trans pan,to the other side of the shaft the shift cable attaches to
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
Did you ever get a your car fixed I'm having the same issues?

I took it back to stock, then updated the Superchips with the lastest tunes. Guess there was something amiss with the tune. Ran fine with the Superchips 87 octane tune until I had lifter failure last year.


Sent from my iPhone using Tapatalk
 
1 - 4 of 4 Posts
Top