Pontiac G8 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Not sure if anyone has seen or experienced this issue, but for the third time now I gotten a mass number of DTC codes (below) that put the car in limp mode.

U0121 ABS
U0101 CM and the EBCM is not working?
P0700 The PCM detected a malfunction in the transmission control system
P2544 Input signal malfunction (TCM and PCM)
P0856 Traction Ctrl
P0073 Power Control Module (PCM)

I may try and look at the TCM and its connector, I do not think the ECU has failed because the car still starts and runs fine but triggers a mass number of DTC codes...

I pulled out all of the fuses and reseated them, cleared the DTC codes then they came back after driving about 10 miles down the road or so its a weird intermittent problem.

Any help or suggestions is appreciated.

I have 62k on the car.

Thanks,
Gary
 

·
Premium Member
Joined
·
4,649 Posts
Is a device plugged in the obd2 (on-board) diagnostic port? If not, might be a loose connection somewhere.
 

·
Registered
Joined
·
2,000 Posts
Check your battery terminals. Also, verify that your alternator is charging
 

·
Premium Member
Joined
·
4,649 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks! So the battery terminals were cleaned, and the alternator is good. I checked ground wires from the trunk battery connector into the engine compartment and also verified the fuses were making clean connections, cleared the DTC no P codes now but they will return...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I just read that thread you sent me thanks! I have not looked under the car, the fellow mentioned his issue was the Bolt which secured the Ground Cable to the chassis... I will check that now.
 
1 - 6 of 6 Posts
Top