Pontiac G8 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 · (Edited)
Anyone else experience issues with third shift studios rear badge deteriorating. I've only had it about 8 months. I first noticed over the winter that the brushed aluminum lettering is coming off and now the strip of aluminum separating the G8 from GT is now peeling.

 

·
Registered
Joined
·
508 Posts
I have had a similar problem with mine but was on the back for a year, I think. Jason from TSS worked with me and gave me a good price on a replacement. Mine was the one that says v8 6.0...looks like the CTS badge with the flag. This one that I have is about 2 yr old and shows some deterioration but not too bad where I want to take it off.
 
Joined
·
66 Posts
Where did you get that?
 

·
Premium Member
Joined
·
5,557 Posts
Joined
·
66 Posts

·
Registered
Joined
·
226 Posts
Jaison is usually pretty good at maintaining customer service, known him a long time
 

·
Mack
Joined
·
1,000 Posts
Damn I didn't know these existed. They have some sweet logo's. Good luck OP.
 
Joined
·
66 Posts
Damn I didn't know these existed. They have some sweet logo's. Good luck OP.
Agreed. I'm really thinking about debadging the rear of my car and just using that badge.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #9 ·
Jaison is usually pretty good at maintaining customer service, known him a long time

I did email him about the issue and he did offer to send me a new one at a significantly lower price. He said to be more careful in the way that I maintain my car... very disappointed that this badge became so weathered in a few short months. My car is garage kept and hand washed, so not sure what I could have done to cause this.

The badge is awesome looking so I'll probably just leave it until it becomes worse looking. I haven't seen any others that I would want to put on the back... Maybe try to find something made out of metal instead of the sticker type emblem?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #11 ·
yeah thats weird, i wonder it was some chemical in your soaps and waxes
I don't know... Mothers car wash and I would have never put any wax over the emblem itself. Not to mention I never actually waxed/polished the car during the time the badge was on the car. Put the badge on Octoberish and first polished the car in April. But I first noticed the issue with the badge in probably late January/February.
 
1 - 11 of 11 Posts
Top