Pontiac G8 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter #1
Alright, this is strange and I will do my best to explain this problem I am having.
About a month ago I noticed that sometimes when I would turn my high beams on, there was a short, and quiet beep of the horn. A few nights after this, I noticed that sometimes my high beams would shut down or dim, when I was not on the throttle (low rpm). This made me question my battery and alternator. Needless to say, I charged the battery and the problem still existed, yet to get the alternator checked.

Now fast forward to last night.....
Was out for a ride, and went to turn on my high beams, nothing. Dash indicator was on, but no change with my lights. Decided I should go home and try to figure x, y, z out. I come to a stop at a stop light, high beams off, and my horn goes off, short beep. Strange...Next stop light, nothing, next stop sign, another horn beep. Try the high beams, works fine, no beep and they light up.

Does anyone have any idea? Fuse? Circuit? PCM? :dunno:
Ultimately I think Bruce is on his way to the dealer for diagnosis, but what can I check in the mean time?
 

·
Registered
Joined
·
105 Posts
There may be a short between the wires in your steering column. When you say they dim, it suggests that another wire is drawing power away from your lights. It may very well be located in the turn signal lever (turn signal combination switch).
 

·
Registered
Joined
·
197 Posts
Discussion Starter #8
Well kids, I hope you all learn from this. 30 minutes into diagnosis, the left headlight ground wire had about 1/2 inch of play. The screw was very loose. Needless to say, the little electric gremlins have all let the building.
 
1 - 9 of 9 Posts
Top