Pontiac G8 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,771 Posts
Discussion Starter · #1 ·
So when I start the car, it will click and nothing. When it does start, it starts fairly strong. Or it will take a second or two once I turn the key. Battery is 3-4 years old but again, once it die start, it’s decent. Have you guys found a common problem? Searching hasn’t come up with anything definitive
 

·
Registered
Joined
·
4,998 Posts
Most likely the brushes in the starter, or the solenoid. Way cheaper than the whole starter.
 

·
Premium Member
Joined
·
8,080 Posts
Original starter? Check the battery, starter and battery ground bolt Pontiac G8 Forum connections. Initially, it appears a portion of the starter is intermittently failing.
 

·
Registered
Joined
·
1,771 Posts
Discussion Starter · #4 ·
Original starter. I knew I should have bought a new one during the engine swap. Replacing the starter with headers is going to be a royal pain as I think the header has to come off.

But this morning it started right away as if nothing was wrong. But will check thanks
 

·
Registered
Joined
·
104 Posts
I would not think that there are bad brushes in the starter. I would look at possibly the relays in the fuse box. Consult your owner's manual re. fuses/relays. I occasionally have a delay start in my 2008 G8 GT with just over 76K miles. My 2009 G8 GT has no starting issues with over 86k miles.
grandpop09
 

·
Registered
2009 GT, Black
Joined
·
572 Posts
I recently had to pull my starter because I forgot to install the cover plate for the flywheel on the passenger side of the car during my build. Yes, I had to pull the header.
 

·
Registered
2012 Caprice PPV Phantom Black
Joined
·
17 Posts
So when I start the car, it will click and nothing. When it does start, it starts fairly strong. Or it will take a second or two once I turn the key. Battery is 3-4 years old but again, once it die start, it’s decent. Have you guys found a common problem? Searching hasn’t come up with anything definitive
I just went through this exact thing with my Caprice. Battery voltage and CCA were fine, and the police package dual battery is still hooked up. So it wasn’t voltage issue for me. Mine started doing it when it got hot. It did it to me 3 times while street tuning the car and I finally bought a new starter. Hasn’t happened since. I’d recommend a heat shield wrap for it too. I wanted to install the camaro heat shield plate, but it doesn’t clear our engine mounts.
 

·
Registered
2012 Caprice PPV Phantom Black
Joined
·
17 Posts
Original starter. I knew I should have bought a new one during the engine swap. Replacing the starter with headers is going to be a royal pain as I think the header has to come off.

But this morning it started right away as if nothing was wrong. But will check thanks
I got mine out with kooks 1-7/8 headers installed. It was tight required some tetris skills. And I had to pry the trans cooler like slightly out of the way. The hardest part was getting to the battery wire nut I had to take both mount bolts, and the harnes plug off before I could get it where I could get that nut off.
 

·
Registered
2009 GT, Black
Joined
·
572 Posts
That was one tricky effort. My luck, I would have gotten the starter loose, then got it wedged in there some way that I would have to pull the header.

Nice job!!
 
1 - 9 of 9 Posts
Top