Pontiac G8 Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter · #1 ·
Just bought my G8 GT last month had alot of issues with only 40,000 miles. Harmonic balancer went out day after i bought it, decoupler pulley on the alternator went out and had to replace entire unit. Now recently the trans has been clicking when putting into gear P to D, D to R and so on. Brought it to the dealer today on the last day of the factory drivetrain warranty and they said they need to pull the transmission because its internal. Anybody else have the same problem?
 

·
Registered
Joined
·
688 Posts
When placing in gear from park to drive I have a very minor clicking nothing major I just assume tranny is engauging
 

·
Registered
Joined
·
688 Posts
And drive to reverse also
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #4 ·
That's what mine does. It's doesn't sound major or like a problem but its not normal. I've owned many GM performance cars and never had this issue. I know the 4L80 is totally different then previous GM cars. But it just didnt seem normal to me and the dealer agreed. The service guy tried to tell me it was the linkage. Totally different noise. Mine clicks when the power is transferred through the trans and engages in gear. Get it checked out. I'm assuming I'm getting a rebuild tranny since there pulling it out.
 

·
Registered
Joined
·
688 Posts
Not sure No slipping or anything and no dealer for me cause of mods with warranty I think I'm good if something comes up I'll take her in
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #7 ·
looks like the only mod you have that voids warranty is the tune. I always have kept a spare ECU (stock tune) so when warranty issues come up you can plug in and get her fixed.
 

·
Registered
Joined
·
688 Posts
Long tubes also no cats lol.....I'm stuck
 

·
Registered
Joined
·
127 Posts
I have the clicking as well. The dealer took my trans apart and repaired for the 2-3 flare issue and so far so good. Even while diagnosing the dealer told me the clicking was the parking sprag and other components engaging and disengaging when moving the shifter from park to reverse, drive and other combinations. I wasn't complaining about that part but rather the stiffness of the shifter sometimes as mentioned by the TSB. After the repair the stiffness is gone, the clicking is not. My grand Prix has the same clicking and my trans in that is pretty much new and built by a very reputable trans builder for that trans model. I believe it is normal.
 

·
Registered
Joined
·
427 Posts
I have a click sound every morning. First time the car rolls forward there is a loud click from the tranny. Then gone until the next day....
 

·
Registered
Joined
·
297 Posts
If you're talking about the click when shifting p to d etc I think that's normal. Maybe that's not what you're referring to, but the action of touching the brake and moving the shifter makes that sound. I swore it was new and faulty at one point, but came to read (here) that it's normal.
 

·
Registered
Joined
·
610 Posts
Mine is quiet on the inside of the car. Before I changed the voice box of the car you could hear it click into gear from the outside. This was any gear, but its only normal for this to happen as it is changing things internally. But again I could only hear this in a stock car standing outside on the driver or passenger side of the car. Most of the times I didn't hear it because of the belt whine. Anything else than this I would get it checked out. (mine is a stock trans non repaired 09.5, tuned it to lessen the flare as I dont trust any GM shop to do the TSB).
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #13 ·
Well i have a couple of friends with g8's and theres don't click. I've read about the clicking on here, but it didn't do it the first week i owned the car with 40k miles. Just thought i would have it documented through the dealer the last day of the warranty, but they ended up pulling it and telling me it wasn't normal. So I'm gonna roll with it and let them pull it apart, fix whatever they find wrong and give me another warranty.
 

·
Registered
Joined
·
688 Posts
Yeah I even noticed after the tranny warms up mine goes away not sure if has anything to do. not thread jacking but speaking f 2-3 flare i never experienced untill going to aftermarket tune started with super chips and than VMS. I guess just kinda deal with
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #15 ·
Finally got my car back after 2 weeks. They told me it was an internal problem and it would be covered under warranty. They ended up replacing the Transmission housing, trans support, trans filter and every seal and gasket. Didn't replace any internal moving parts from the part numbers i looked up. They also called GM to let them know and GM informed the dealer they know of the problem and they just gave them a case number and said its normal. Trans feels a little stronger and shifts smoother, because of the new fluid and seals I'm assuming.
 
1 - 15 of 15 Posts
Top