Pontiac G8 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1
Issue #1...
Last night driving to work the check engine light came on as I was slowing down to get off the highway. Went to lunch and the light was still on. After work I started the car and it went off. I stopped by AZ right by work to check what the code was (U0101). From what I have read it is a communication problem with the TCM. What are some possible causes for this and should I be worried? I just got the car 3 weeks ago. Could the car have been de-modded and they didn't flash back to the stock tune causing some miscommunication?

Issue #2...
Went to get my oil changed this morning and they were unable to get the housing off the oil filter. It is completely seized. What this tells me is that the filter has not been changed in a loooong time. So the dealership did a half ass oil change when they got the car (if at all) and didn't bother to fix the problem. Anyone ever run into this? Possible solutions?

Thanks in advance for any help/suggestions.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #2
OK...i got the oil filter housing off. I took a chance and used a breaker bar and luckily didn't crack the thing.

Any help on the U0101?
 

·
Registered
Joined
·
1,210 Posts
U codes can pop up randomly. I would wait until the light stays on and you can pull a P code.

As to the oil cap. They barely have to be snug. One bit of over tightening them can make it a biotch to get off at the next oil change. I use my Snap On 3/8" impact on 75% of them to loosen
 

·
Registered
Joined
·
316 Posts
Issue #1...
Last night driving to work the check engine light came on as I was slowing down to get off the highway. Went to lunch and the light was still on. After work I started the car and it went off. I stopped by AZ right by work to check what the code was (U0101). From what I have read it is a communication problem with the TCM. What are some possible causes for this and should I be worried? I just got the car 3 weeks ago. Could the car have been de-modded and they didn't flash back to the stock tune causing some miscommunication?

Issue #2...
Went to get my oil changed this morning and they were unable to get the housing off the oil filter. It is completely seized. What this tells me is that the filter has not been changed in a loooong time. So the dealership did a half ass oil change when they got the car (if at all) and didn't bother to fix the problem. Anyone ever run into this? Possible solutions?

Thanks in advance for any help/suggestions.


Conditions for Running the DTC

The system voltage is between 9–16 volts.

Conditions for Setting the DTC

A supervised periodic message that includes the transmitter module availability has not been received.

Action Taken When the DTC Sets

Specific subsystems will not function.
DTC U0100 in the TCM will cause the transmission to go into default gears.
Both DTC U0100 in the TCM and DTC U0101 in the ECM will cause the malfunction indicator lamp (MIL) to illuminate.
Conditions for Clearing the DTC

The ECM/TCM turns OFF the MIL after 4 consecutive ignition cycles that the diagnostic runs and does not fail.


Clear it and it will more than likely never reappear.

If it does, you may have a bad connection between the ECM and TCM through the GM High Speed Serial Bus. Didn't we just have someone else on here with this code?
 

·
every village has one
Joined
·
2,170 Posts
Not sure of this, but aren't V6's running a tune pretty rare?
 

·
Registered
Joined
·
112 Posts
Discussion Starter #6
U codes can pop up randomly. I would wait until the light stays on and you can pull a P code.

As to the oil cap. They barely have to be snug. One bit of over tightening them can make it a biotch to get off at the next oil change. I use my Snap On 3/8" impact on 75% of them to loosen
1/2" impact was next if the breaker bar didn't do it. :)

All of my other cars have been screw on filters. This is the first one with a cartridge. The one in there was pretty nasty, but I don't know if that is normal. I will probably change the filter again soon just to see if it is pulling a lot of crud out of the oil.

Thanks for the heads up on the cap. I tried to find OEM torque specs but couldn't.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #7
Conditions for Running the DTC

The system voltage is between 9–16 volts.

Conditions for Setting the DTC

A supervised periodic message that includes the transmitter module availability has not been received.

Action Taken When the DTC Sets

Specific subsystems will not function.
DTC U0100 in the TCM will cause the transmission to go into default gears.
Both DTC U0100 in the TCM and DTC U0101 in the ECM will cause the malfunction indicator lamp (MIL) to illuminate.
Conditions for Clearing the DTC

The ECM/TCM turns OFF the MIL after 4 consecutive ignition cycles that the diagnostic runs and does not fail.


Clear it and it will more than likely never reappear.

If it does, you may have a bad connection between the ECM and TCM through the GM High Speed Serial Bus. Didn't we just have someone else on here with this code?
Thanks...will keep an eye on it. :)
 

·
Registered
Joined
·
112 Posts
Discussion Starter #8
Not sure of this, but aren't V6's running a tune pretty rare?
No idea...I am new to the mod/tuning scene. I plan on doing a tune on mine when I get my exhaust system done.
 

·
Registered
Joined
·
1,336 Posts
absolutely rare to see a V6 with a tune. I thought there were only a handful on the board with a tune. maybe things have changed and the V6 crowd have more tuning options...don't know.
 

·
Premium Member
Joined
·
2,191 Posts
Mace has a tune. And trinity has one to. Best bet check in v6 section on this, hazer has led the charge in this section. Not a whole lot to do on the LY7. It is a stout motor in a 4, 000 # car. Trust me been there tryed it..

From the outer most of a uncharted galaxy! !
 

·
OGOC Member
Joined
·
2,602 Posts
Ya the LY7 has a weird tune that not too many can mess with.
 

·
Premium Member
Joined
·
2,191 Posts
All I did to my Base was Solo axle backs CAI deleted the mid muffler with x-pipe and resonaters, and put down 223 RWH. Hazer with the tune was at 242.










From the outer most of a uncharted galaxy! !
 

·
OGOC Member
Joined
·
2,602 Posts
All I did to my Base was Solo axle backs CAI deleted the mid muffler with x-pipe and resonaters, and put down 223 RWH. Hazer with the tune was at 242.
I basically have what the same setup as you and im waiting to hear from a friend of mine about a tune for our LY7
 

·
Registered
Joined
·
1,210 Posts
1/2" impact was next if the breaker bar didn't do it. :)

All of my other cars have been screw on filters. This is the first one with a cartridge. The one in there was pretty nasty, but I don't know if that is normal. I will probably change the filter again soon just to see if it is pulling a lot of crud out of the oil.

Thanks for the heads up on the cap. I tried to find OEM torque specs but couldn't.
Spec is on the cap I believe. Something like 24nm
 
1 - 14 of 14 Posts
Top