Pontiac G8 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So I recently purchased the cheapest non-wrecked G8 on planet Earth.

Its a First 888 Ignition Orange Metallic LY7 V6 with 151K.

It reportedly has a problem, maybe fatally... in which case its getting a new engine, but in the meantime, I'm trying to suss out what I have.

After fighting with a broken hood cable and general difficulty getting the battery swapped out for a fresher one, the car does attempt to start and sounds OK.

After a bit more playing, I realized the engine, as purchased is missing two devices on the right bank and one on the left. Also a spark plug was conveniently left out. Lovely. I'm not sure if the car was harvested for some parts or if these parts were removed as part of the diagnosis.

Two of the plugs are orange and one is a light green. I'm not sure if they are sensors or solenoids. I assume that without these devices and only 5 spark plugs, this car isn't going to start.

After reading up on the 3.6 (I'm more of a 3800 guy), I see that there are numerous issues with the cams and timing and even the oil pump. I want to get started with a baseline to ensure I'm dealing with a repairable engine... so before I do a compression test or drop my inspection camera into the spark plug holes, I'd like to ensure I have oil pressure. Is there a way to easily test this, besides watching the odd gauge on the dash?

Are all the cam sensors and solenoids the same part? Also, does anyone know what size bolts hold these on? And hold the coil packs on? Unfortunately, along with the missing parts, the bolts are gone.

Besides the G8, what other 3.6 equipped cars are potential part donors? I'd rather put some junkyard parts on to test out the engine... but I'm not ruling out having to swap out the long block.

Any thoughts? Sorry so long... and info would be appreciated.

BKNJ
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Oh, I forgot to mention...

I wasn't getting any codes or a check engine light.

The engine does have oil... dirty, but not full of metal or milkshake.

Whats exactly is the oil gauge on the dash measuring? I see the engine has a oil level and temperature sensor, but didn't see a oil pressure sender.

BKNJ
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Do you have any pictures of what you're talking about?
Yes, actually. I have some photos of the empty holes on the front of the right head and the connectors. I will upload as soon as my phone recharges... well, and I recharge... its been a long day.

BKNJ
 

·
Registered
Joined
·
140 Posts
FYI, I just replaced my 3.6L engine and I pulled off a lot of the sensors, servos and other reusable parts off of the old engine.

I plan on Ebaying the parts to recoup some of my loss. I can post pictures of all of the parts tonight if you want to see if I have what you need.
 

·
Registered
Joined
·
140 Posts
The parts will consist of cam sensors, crank sensors, servos, oil pressure, fuel lines, ignition coils, intake manifold, vacuum lines, fuel injectors, water pump, thermostat with housing, high pressure fuel lines, intake manifold, engine wiring harness, idler pulley and a crap more.

Reagarding the oil pressure I don't use the dash one as a guide, I used Dashboss to give me accurate readings straight from the OBD directly to my tablet via Bluetooth.

As far as your missing bolts go, I have a tons left over from my swap I can provide to you
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Do you have any pictures of what you're talking about?
These are the pictures of the two different types of connectors... and the front of the right head (left head is obscured by accessories). Spot denoted with yellow arrow is empty, IIRC.

Car is not at my current location.

BKNJ
 

Attachments

1 - 7 of 7 Posts
Top