Pontiac G8 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey anyone out there with 2009 V6 G8 that started having issues with their car miss firing causing their engine to shake violently; forcing them to turn the car off and restart it and then the car run fine after that? Then experience in below 10 degrees Fahrenheit and then the car won't start and just keep on cranking? I have been experiencing these issues the past couple of weeks and when it wouldn't start it took over 2 hours to get it started. I am a very handy mechanic and know a lot about car, but this is confusing me.
 

·
Registered
Joined
·
296 Posts
I would get some seafoam intake cleaner and run that through it...it's the one with the little tube where you hook it up to the throttle body. Keep these engines clean is paramount. I'd also get a bottle of the seafoam that you pour and put 1/2 of it in the gas tank and the other 1/2 in the oil. Change oil after about a couple hundred miles.
 

·
OGOC Member
Joined
·
2,602 Posts
I know the number 6 coil (drivers side rear) get wet over time. On most v6s. I had the issue of rough running and found that it was that coil getting water in there. So check that first.
 

·
Registered
Joined
·
138 Posts
Did it go into safety mode? Mine did that last year, during the winter cold. (not blaming that.....but I wonder). Ended up being the Throttle Body sensor. (under $50 repair)....knock on wood...nothing since then. I had thought it was a bad tank of gas at first.
 
1 - 4 of 4 Posts
Top