Pontiac G8 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I drove my G8 into work this morning. It won't seem to shift out of 3rd gear. When I'm in manual mode I can't downshift or shift up. The shift indicator never reflects anything but S3.

From a complete stop it takes off in first gear and seems to be shifting up to 3rd gear. When I'm driving it feels more like second gear.

I see an engine light on the top left side of my dashboard. I'll check my transmission fluid level and see if there is an error code that reveals anything.

Please advise.

Paul
Parker, Colorado
 

·
Registered
Joined
·
1,545 Posts
The input/output speed sensor can be problematic when things get too hot. Clear the codes then go for a drive around the block and see if it goes away.

Obviously there will be a few codes stored. At least one will be a generic trouble code. I don't remember what it was when this came up for me; maybe U0700 or something like that. The other was U0716 (or similar). This was a while ago for me and I'm going from memory only. There was a third code as well.

It may go away and not come back when you clear the codes, but that doesn't mean the problem is fixed.
 

·
Registered
Joined
·
76 Posts
had a similar problem after emissions check - CEL - code P0700

The input/output speed sensor can be problematic when things get too hot. Clear the codes then go for a drive around the block and see if it goes away.

Obviously there will be a few codes stored. At least one will be a generic trouble code. I don't remember what it was when this came up for me; maybe U0700 or something like that. The other was U0716 (or similar). This was a while ago for me and I'm going from memory only. There was a third code as well.

It may go away and not come back when you clear the codes, but that doesn't mean the problem is fixed.
This problem was actually caused by a faulty OBDII checking unit. During the initial attempt by the checker to hook up the unit a CEL light appeared on the DIC . Car failed emissions check and was called out as a 'transmission fail'. When I left the checking station the car was locked into S2 and would not shift up or down, nor would it shift manually. Stopped at a transmission place I deal with and they checked the code which said a main communication buss to TCM was not communicating. They reset the code and the car/transmission returned to normal. This was mid March and it has been fine since.

Another emission checking station retested the car and it passed and has been fine since. They, in fact, said the other checking station had caused the CEL because of faulty equipment. Of course you may have a different problem/cause, but I thought this might be helpful.

I since have bought an analyzer to carry with me - they are cheap - and it has already paid for itself on my 2009 Solstice GXP.

grandpop09
 

·
Registered
Joined
·
1,545 Posts
I'm confused, are you posting for the OP?
 
1 - 5 of 5 Posts
Top